Bug 136444 - sound stops working or won't work at all
sound stops working or won't work at all
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 22:28 EDT by G. Vincent Castellano
Modified: 2015-01-04 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-19 08:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G. Vincent Castellano 2004-10-19 22:28:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041010

Description of problem:
IBM T23 laptop, sound hardware described in /etc/sysconfig/hwconf as:

driver: snd-intel8x0
desc: "Intel Corp. 82801CA/CAM AC'97 Audio Controller"

Sound may work (through xmms) when machine is first booted, but then
stops after some period of time, bringing up it's generic 'couldn't
open audio' error dialog.  No other applications are accessing the
sound devices (/dev/dsp, /dev/mixer).  The 'snd' sound editing
application hangs when attempting to play any sound.  Stack trace:

#0  0x004cf782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00732a55 in open64 () from /lib/tls/libpthread.so.0
#2  0x00000000 in ?? ()



Version-Release number of selected component (if applicable):
alsa-lib-1.0.6-1

How reproducible:
Always

Steps to Reproduce:
1. Start and stop xmms until it reports the sound device is not
accessible.
    

Actual Results:  xmms reports "Couldn't Open Audio"

Expected Results:  xmms should play tunes!

Additional info:
Comment 1 Bill Nottingham 2004-10-19 22:44:48 EDT
Which output plugin are you using?

Do other apps besides 'snd' fail?
Comment 2 G. Vincent Castellano 2004-10-20 15:02:26 EDT
Using ALSA 1.2.10 output plugin with xmms.  snd does not have plugins.
 Sox will also hang trying to play a sound.
Comment 3 Bill Nottingham 2004-10-20 15:20:33 EDT
If sox hangs, and nothing else is accessing the device, sounds like a
kernel problem. 
Comment 4 G. Vincent Castellano 2004-10-20 15:36:58 EDT
So if this is a kernel problem, should I redirect this bug?

In /var/log/messages, I see:

Oct 20 13:27:55 gvc kernel: application snd uses obsolete OSS audio
interface

Should I rebuild snd on FC3?  I am still using the version I compiled
on RH9.

Note also in the message log there is:

Oct 19 06:40:32 gvc kernel: application mozilla-bin uses obsolete OSS
audio interface

My Mozilla RPMs are all 1.7.3-12.  How bad is it if something is
accessing sound via OSS?  Is it 'unsafe'?  And if so, is it a bug that
FC3 Mozilla is doing so?
Comment 5 G. Vincent Castellano 2004-10-25 13:15:06 EDT
This happened to me again, and on a hunch I shutdown Mozilla.  My
other apps started working.

/sbin/fuser on /dev/dsp and /dev/mixer didn't show any processes
having these devices open so I don't know exactly what's cauing this.
 I plan to wipe my machine and reload with the release candidate
because I've got other 'issues' possibly related to doing an upgrade
from RH9.  After I've done that I'll report back if I find this
problem persists.
Comment 6 Dave Jones 2005-07-15 16:30:30 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 G. Vincent Castellano 2005-07-19 08:37:38 EDT
Problem was resolved following a complete reinstall of FC3.

Note You need to log in before you can comment on or make changes to this bug.