Bug 1364452 - IPA server install fails with latest 389-ds-base build
Summary: IPA server install fails with latest 389-ds-base build
Keywords:
Status: CLOSED DUPLICATE of bug 1316580
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 11:35 UTC by Kaleem
Modified: 2016-08-09 13:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 13:07:15 UTC


Attachments (Terms of Use)

Description Kaleem 2016-08-05 11:35:50 UTC
Description of problem:
This issue seen with build 389-ds-base-1.3.5.10-6.el7. After downgrade to 389-ds-base-1.3.5.10-5.el7, IPA Server install is successfull

Version-Release number of selected component (if applicable):
389-ds-base-1.3.5.10-6.el7

How reproducible:
Always

Steps to Reproduce:
1.Install IPA server with 389-ds-base-1.3.5.10-6.el7
2.
3.

Actual results:
Install fails

Expected results:
Install should be successful.

snip from /var/log/message:
===========================
Aug  5 15:40:27 dhcp207-129 systemd: Reloading.
Aug  5 15:40:27 dhcp207-129 systemd: Created slice system-dirsrv.slice.
Aug  5 15:40:27 dhcp207-129 systemd: Starting system-dirsrv.slice.
Aug  5 15:40:27 dhcp207-129 systemd: Starting 389 Directory Server TESTRELM-TEST....
Aug  5 15:40:27 dhcp207-129 systemd: Failed at step EXEC spawning /usr/sbin/ds_systemd_ask_password_acl: No such file or directory
Aug  5 15:40:27 dhcp207-129 systemd: dirsrv@TESTRELM-TEST.service: control process exited, code=exited status=203
Aug  5 15:40:27 dhcp207-129 systemd: Failed to start 389 Directory Server TESTRELM-TEST..
Aug  5 15:40:27 dhcp207-129 systemd: Unit dirsrv@TESTRELM-TEST.service entered failed state.
Aug  5 15:40:27 dhcp207-129 systemd: dirsrv@TESTRELM-TEST.service failed.
Aug  5 15:40:28 dhcp207-129 ntpd[12175]: 0.0.0.0 c515 05 clock_sync
Aug  5 15:50:01 dhcp207-129 systemd: Started Session 15 of user root.
Aug  5 15:50:01 dhcp207-129 systemd: Starting Session 15 of user root.
Aug  5 15:50:33 dhcp207-129 systemd: Starting System Security Services Daemon...
Aug  5 15:50:33 dhcp207-129 sssd: Configuration file: /etc/sssd/sssd.conf does not exist.
Aug  5 15:50:33 dhcp207-129 systemd: sssd.service: control process exited, code=exited status=4
Aug  5 15:50:33 dhcp207-129 systemd: Failed to start System Security Services Daemon.
Aug  5 15:50:33 dhcp207-129 systemd: Unit sssd.service entered failed state.
Aug  5 15:50:33 dhcp207-129 systemd: sssd.service failed.
Aug  5 15:50:33 dhcp207-129 systemd: Reached target User and Group Name Lookups.
Aug  5 15:50:33 dhcp207-129 systemd: Starting User and Group Name Lookups.
Aug  5 15:50:37 dhcp207-129 ntpd[12175]: ntpd exiting on signal 15
Aug  5 15:50:37 dhcp207-129 systemd: Stopping Network Time Service...
Aug  5 15:50:37 dhcp207-129 systemd: Stopped Network Time Service.


/var/log/
[root@dhcp207-129 slapd-TESTRELM-TEST]# cat errors
	389-Directory/1.3.5.10 B2016.217.2052
	dhcp207-129.testrelm.test:389 (/etc/dirsrv/slapd-TESTRELM-TEST)

[05/Aug/2016:15:40:25.414547234 +051800] WARNING: Import is running with nsslapd-db-private-import-mem on; No other process is allowed to access the database
[05/Aug/2016:15:40:25.426596856 +051800] check_and_set_import_cache: pagesize: 4096, pages: 254123, procpages: 2919
[05/Aug/2016:15:40:25.438591654 +051800] WARNING: After allocating import cache 250156KB, the available memory is 766336KB, which is less than the soft limit 1048576KB. You may want to decrease the import cache size and rerun import.
[05/Aug/2016:15:40:25.450428481 +051800] Import allocates 250156KB import cache.
[05/Aug/2016:15:40:25.491502640 +051800] import userRoot: Beginning import job...
[05/Aug/2016:15:40:25.506663585 +051800] import userRoot: Index buffering enabled with bucket size 100
[05/Aug/2016:15:40:25.707822823 +051800] import userRoot: Processing file "/var/lib/dirsrv/boot.ldif"
[05/Aug/2016:15:40:25.721499328 +051800] import userRoot: Finished scanning file "/var/lib/dirsrv/boot.ldif" (1 entries)
[05/Aug/2016:15:40:26.220905908 +051800] import userRoot: Workers finished; cleaning up...
[05/Aug/2016:15:40:26.433803715 +051800] import userRoot: Workers cleaned up.
[05/Aug/2016:15:40:26.448674581 +051800] import userRoot: Cleaning up producer thread...
[05/Aug/2016:15:40:26.460281664 +051800] import userRoot: Indexing complete.  Post-processing...
[05/Aug/2016:15:40:26.472881411 +051800] import userRoot: Generating numsubordinates (this may take several minutes to complete)...
[05/Aug/2016:15:40:26.500729305 +051800] import userRoot: Generating numSubordinates complete.
[05/Aug/2016:15:40:26.515537139 +051800] import userRoot: Gathering ancestorid non-leaf IDs...
[05/Aug/2016:15:40:26.528392614 +051800] import userRoot: Finished gathering ancestorid non-leaf IDs.
[05/Aug/2016:15:40:26.552716703 +051800] Nothing to do to build ancestorid index
[05/Aug/2016:15:40:26.567248077 +051800] import userRoot: Created ancestorid index (new idl).
[05/Aug/2016:15:40:26.580417917 +051800] import userRoot: Flushing caches...
[05/Aug/2016:15:40:26.592597731 +051800] import userRoot: Closing files...
[05/Aug/2016:15:40:26.663976616 +051800] All database threads now stopped
[05/Aug/2016:15:40:26.676495128 +051800] import userRoot: Import complete.  Processed 1 entries in 1 seconds. (1.00 entries/sec)
[root@dhcp207-129 slapd-TESTRELM-TEST]#

Comment 5 Kaleem 2016-08-09 13:07:15 UTC

*** This bug has been marked as a duplicate of bug 1316580 ***


Note You need to log in before you can comment on or make changes to this bug.