Bug 136448 - Thunar/xffm shows generic icon if file extension changed
Thunar/xffm shows generic icon if file extension changed
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 23:09 EDT by Andrew Farris
Modified: 2008-01-06 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 17:52:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2004-10-19 23:09:34 EDT
Description of problem:
The incorrect icon is shown (or a generic icon) for files which have no filetype
extension in the name, yet have a recognizable MIME type.  An RPM has a 'box'
package icon, yet if it is named *.rp the icon will no longer be used.  The file
properties in xffm still shows the file as a recognized RPM.  The same is true
of any other type I've tried which has non-generic icon used.  Extensions should
not be used to determine filetype.

Version-Release number of selected component (if applicable):
xffm-4.0.6-1
xffm-icons-4.0.6-2

If this is actually the way xffm is choosing the icon then this belongs upstream
and I'll report it there as well.
Comment 1 Andrew Farris 2008-01-05 06:58:10 EST
This issue is still present in FC8's Thunar (xffm replacement) but is now
slightly different.

If an RPM package is renamed to .rp or .txt then the appropriate icon is used
for that extension but both are incorrect for the actual file... (realpix is .rp)

However, if no extension is there, or one that is undefined like .r then it will
instead use the RPM icon and identify the file as type rpm package.

It seems that extensions are trusted as correct if present and defined and
otherwise the file's MIME type is used?

Intentional or not, this seems to be backwards to me.  If the file itself claims
a type shouldn't it be used rather than the extension and only trust the
extension as correct when its ambiguous?

Nautilus recognizes the file to be RPM in all the above cases and the package
icon is always used.  Thunar behaves differently and changes the icons based on
extension.
Comment 2 Andrew Farris 2008-01-05 20:04:00 EST
Filed upstream:  http://bugzilla.xfce.org/show_bug.cgi?id=3788
Comment 3 Kevin Fenzi 2008-01-06 00:17:15 EST
Hey Andrew. 

I took over the Xfce packages from Than quite a while ago... this bug must have
been filed before then and not gotten changed over to me. 
I just happened to notice it go by. 

Thank you for updating things and filing upstream... 
Comment 4 Andrew Farris 2008-01-06 01:30:47 EST
Yes I filed it long ago and forgot about it since I wasn't using XFCE anymore.

I should mention that this is not only an icon issue... if an RPM package is double clicked while its name 
has the .rp extension Thunar will attempt to open the file with VLC media player (on my system).  This is 
clearly not correct behavior (I'll clarify that upstream too).
Comment 5 Andrew Farris 2008-01-06 17:52:49 EST
Benny at xfce closed this upstream as invalid since it is expected behavior, and says the difference in 
nautilus and thunar should disappear when thunar is using GVfs (I guess that is planned).  So I suppose 
this is deferred to later.

Note You need to log in before you can comment on or make changes to this bug.