Bug 136453 - [x86_64][httx] multiple instance of httx process
[x86_64][httx] multiple instance of httx process
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-10-20 01:49 EDT by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: iiimf-12.2-0.2.svn2578
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 02:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-10-20 01:49:54 EDT
Description of problem:
In the x86_64 arch, it was noticed that there were more than one
instance of httx running and htt_xbe process running, while in the
i386 arch, there is one instance of httx and one instance of htt_xbe.

Version-Release number of selected component (if applicable):
im-sdk-12.1-1

How reproducible:
Always

Steps to Reproduce:
1.log in as normal user with zh_CN locale /GNOME session
2.start gnome-terminal
3.ps -auxwww |grep htt
  
Actual results:
[llim@dhcp-209 ~]$ ps -aux |grep httx
Warning: bad syntax, perhaps a bogus '-'? See
/usr/share/doc/procps-3.2.3/FAQ
llim      3670  0.0  0.1 47948 1440 ?        S    15:39   0:00 httx
llim      4373  0.0  0.1 47948 1440 ?        S    15:46   0:00 httx
llim      4375  0.0  0.0 41436  656 pts/2    R+   15:46   0:00 grep htt

Expected results:
One httx process only.

Additional info:
Comment 1 Lawrence Lim 2004-10-20 02:19:26 EDT
My apologies, the version for the bug reported in im-sdk-12.1-2.

Snapshot taken taken i386 machine with the same im-sdk version 12.1-2.

[llim@dhcp-216 ~]$ ps -aux |grep htt
Warning: bad syntax, perhaps a bogus '-'? See
/usr/share/doc/procps-3.2.3/FAQ
llim     19201  0.0  0.5  6092 1344 ?        S    12:20   0:00 httx
llim     19203  0.0  1.3 24060 3284 ?        Sl   12:20   0:00 htt_xbe
llim     19832  0.0  0.2  3880  672 pts/6    R+   15:44   0:00 grep htt
Comment 2 Lawrence Lim 2004-10-20 02:31:19 EDT
I just noticed that even htt_server is running multiple instances on
the x86_64 arch machine. Previously not shown because I did service
iiim stop to shut down the htt_server.


[llim@dhcp-209 ~]$ ps -aux |grep htt
Warning: bad syntax, perhaps a bogus '-'? See
/usr/share/doc/procps-3.2.3/FAQ
htt       6831  0.0  0.0  3528  348 ?        Ss   16:27   0:00
/usr/sbin/htt -retryonerror 0
htt       6832  0.0  0.4 51764 4544 ?        S    16:27   0:00
htt_server -nodaemon
root      6883  0.0  0.0  3528  336 ?        Ss   16:28   0:00 htt
root      6884  0.0  0.6 53848 6632 ?        Sl   16:28   0:00
htt_server -nodaemon
llim      7447  0.0  0.1 47948 1436 ?        S    16:31   0:00 httx
llim      7585  0.0  0.1 47948 1436 ?        S    16:32   0:00 httx
llim      7587  0.0  0.0 41436  656 pts/1    R+   16:32   0:00 grep htt
Comment 3 Lawrence Lim 2004-10-20 03:22:27 EDT
Please ignore Comment #2, this is the correct one after I did a restart.


[llim@dhcp-209 ~]$ ps -aux |grep htt
Warning: bad syntax, perhaps a bogus '-'? See
/usr/share/doc/procps-3.2.3/FAQ
htt       2783  0.0  0.0  3528  348 ?        Ss   16:58   0:00
/usr/sbin/htt -retryonerror 0
htt       2784  0.0  0.6 53772 6464 ?        Sl   16:58   0:00
htt_server -nodaemon
llim      3654  0.0  0.1 47948 1440 ?        S    17:22   0:00 httx
llim      3944  0.0  0.1 47948 1440 ?        S    17:23   0:00 httx
llim      3946  0.0  0.0 41436  656 pts/1    R+   17:23   0:00 grep htt
Comment 4 Leon Ho 2004-12-08 20:31:33 EST
This should be solved along with the crash fix, right?
Comment 5 Lawrence Lim 2005-04-26 02:15:50 EDT
Confirmed fixed. Tested with iiimf-12.2-0.2.svn2578.


Thanks.

Note You need to log in before you can comment on or make changes to this bug.