Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1364604

Summary: Upstream Bug 56925 - ErrorDocument directive misbehaves with mod_proxy_http and mod_proxy_ajp
Product: Red Hat Enterprise Linux 7 Reporter: Joe <bugzilla.redhat.com>
Component: httpdAssignee: Luboš Uhliarik <luhliari>
Status: CLOSED ERRATA QA Contact: Jan Houska <jhouska>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.4CC: isenfeld, jorton, luhliari, mfrodl, mmiura
Target Milestone: rcKeywords: Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: httpd-2.4.6-58.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 21:36:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Patch fixing the issue none

Description Joe 2016-08-05 22:25:16 UTC
Description of problem:
If custom error responses are configured with ErrorDocument and mod_proxy_http or mod_proxy_ajp is used, httpd will wait for the configured proxytimeout before serving the error document.

Version-Release number of selected component (if applicable):
2.4.6-40.el7.x86_64

How reproducible:
Create the following test configuration:
ErrorDocument 404 http://bugzilla.redhat.com
ProxyErrorOverride on
ProxyPass / http://127.0.0.1/nonexistant
ProxyPassReverse / http://127.0.0.1/nonexistant

Steps to Reproduce:
1. Open http://127.0.0.1/ in a webbrowser

Actual results:
It takes 20 seconds until the redirect to http://bugzilla.redhat.com is executed.
The time this takes can be "adjusted" by changing the proxy timeout parameter, for example 5 seconds: ProxySet timeout=5

Expected results:
The redirect to http://bugzilla.redhat.com is executed immediately.

Additional info:
The same error also occurs for ErrorDocument 500, 503 etc. configurations.
The bug was already fixed upstream: https://bz.apache.org/bugzilla/show_bug.cgi?id=56925

Comment 4 Luboš Uhliarik 2016-09-26 13:52:29 UTC
Created attachment 1204843 [details]
Patch fixing the issue

Comment 11 errata-xmlrpc 2017-08-01 21:36:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2175