Bug 1364712 - Missing Atomic host kickstart trees
Summary: Missing Atomic host kickstart trees
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-06 12:45 UTC by Matthew York
Modified: 2019-09-25 21:20 UTC (History)
15 users (show)

Fixed In Version: pulp-rpm-2.8.3.6-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-04 06:44:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification screenshot (57.14 KB, image/png)
2016-09-28 14:56 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 2211 Normal CLOSED - CURRENTRELEASE As a user, I can sync a distribution unit with the existing yum_importer without requiring yum metadata 2016-12-19 16:01:37 UTC
Pulp Redmine 2224 Urgent CLOSED - CURRENTRELEASE Cannot sync from mirrorlists 2016-12-19 16:01:30 UTC
Red Hat Product Errata RHBA-2016:1993 normal SHIPPED_LIVE Satellite 6.2.2 Async Bug Release 2016-10-04 10:43:20 UTC

Description Matthew York 2016-08-06 12:45:34 UTC
Description of problem:
Satellite 6.2 is missing the kickstart trees for Red Hat Atomic Host. This means we cannot provision Atomic host nodes directly from satellite using DHCP/PXE.

Version-Release number of selected component (if applicable):
Satellite 6.2.0


How reproducible:
Repeatedly


Steps to Reproduce:
1. Look at Red Hat repositories
2. Under kickstart trees
3. No kickstart content available for atomic host.

Actual results:
This means I'm unable to provision Atomic host from Satellite using DHCP/PXE

Expected results:
I expected to find a kickstart tree so I could provision hosts.


Additional info:
I was able to work around this by copying the content into /var/www/html/pub/atomic then creating a custom installation media that points to this URL.

Comment 4 pulp-infra@redhat.com 2016-08-26 01:08:18 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 5 pulp-infra@redhat.com 2016-08-26 01:08:21 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 6 pulp-infra@redhat.com 2016-08-26 17:30:24 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 7 Michael Hrivnak 2016-09-13 15:22:59 UTC
I'm associating another pulp issue that is a critical bug fix that must be cherry-picked with the original change, to ensure that mirrorlist support during sync continues to work.

Comment 8 pulp-infra@redhat.com 2016-09-13 15:31:34 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 9 pulp-infra@redhat.com 2016-09-13 15:31:38 UTC
The Pulp upstream bug priority is at Urgent. Updating the external tracker on this bug.

Comment 12 jcallaha 2016-09-28 14:32:39 UTC
Verified in Satellite 6.2.2 Async Snap 1.

Kickstart tree for RHEL Atomic Host is now available. See attached screenshot for verification evidence.

Comment 13 jcallaha 2016-09-28 14:56:44 UTC
Created attachment 1205507 [details]
verification screenshot

Comment 15 errata-xmlrpc 2016-10-04 06:44:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1993

Comment 16 pulp-infra@redhat.com 2016-10-26 05:01:18 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 17 pulp-infra@redhat.com 2016-10-26 05:01:26 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 18 pulp-infra@redhat.com 2016-12-13 16:01:32 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 19 pulp-infra@redhat.com 2016-12-19 16:01:31 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 20 pulp-infra@redhat.com 2016-12-19 16:01:38 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.


Note You need to log in before you can comment on or make changes to this bug.