Bug 1364950 - Unreadable and inaccurate repository description in the web console
Summary: Unreadable and inaccurate repository description in the web console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 09:32 UTC by Maciej Szulik
Modified: 2017-03-08 18:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Configuring a build to use a GitHub git source and setting a context dir or ref. Consequence: The source repo appears as the full link to the context dir / ref in GitHub, which is a long unreadable URL. Fix: The web console was updated to not show the full link. Result: The visual representation of the source repo is only the source repo, the target of the link includes the context dir and ref.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:42:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Repository description (12.56 KB, image/png)
2016-08-08 09:32 UTC, Maciej Szulik
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Maciej Szulik 2016-08-08 09:32:02 UTC
Created attachment 1188583 [details]
Repository description

Description of problem:
The information presented in web console BuildConfig's description shows me:
Source repo: https://github.com/soltysh/talks/tree/master/2015/pyconpl%2Fsrc%2Fblast-image
Source context dir: 2015/pyconpl/src/blast-image

The context dir is correct, but the repo from CLI is:
URL: https://github.com/soltysh/talks.git

The problem is getting worse if this URL is getting longer which makes in 
even less readable. 

Version-Release number of selected component (if applicable):
GCE dedicated, Hack Day 08/08

How reproducible:
Always

Steps to Reproduce:
1. Create a BuildConfig with context dir set
2. Go to overview page of that BuildConfig

Actual results:
Unreadable information about the source repo

Expected results:
The text should show me just the actual repo, but the underlying link
should be pointing to the path that's currently there, iow the repo
with the context dir.

Additional info:
none

Comment 1 Maciej Szulik 2016-08-08 12:03:47 UTC
The same problem applies to builds list.

Comment 2 Jessica Forrester 2016-08-10 13:14:58 UTC
https://github.com/openshift/origin-web-console/pull/335

Comment 3 Jessica Forrester 2016-08-11 12:40:28 UTC
merged into origin-web-console and OSE, merging to origin in https://github.com/openshift/origin/pull/10355

Comment 4 Yadan Pei 2016-08-12 02:47:11 UTC
Checked against v3.3.0.18

1. Create app from image python:2.7 
Set Git Repository URL: https://github.com/openshift/sti-python.git
Set Context Dir: 2.7/test/django-test-app

2. Check BuildConfig configuration tab
Source repo: https://github.com/openshift/sti-python.git
Source ref:  master
Source context dir: 2.7/test/django-test-app

Source repo text shows the exact repo configured "https://github.com/openshift/sti-python.git"

Click on the link points to the repo with the context dir 
"https://github.com/sclorg/s2i-python-container/tree/master/2.7/test/django-test-app"

Comment 5 Yadan Pei 2016-08-12 02:47:51 UTC
Move to VERIFIED since it works as expected now

Comment 7 errata-xmlrpc 2016-09-27 09:42:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.