Bug 1364969 - "Pre-release" page not need anymore in RC phase.
Summary: "Pre-release" page not need anymore in RC phase.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.0.2
: ---
Assignee: Joey Boggs
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 10:01 UTC by cshao
Modified: 2017-01-16 23:23 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:08:29 UTC
oVirt Team: Rel-Eng
Target Upstream Version:


Attachments (Terms of Use)
pre-release (117.15 KB, image/png)
2016-08-08 10:01 UTC, cshao
no flags Details
pre-release2 (106.08 KB, image/png)
2016-08-08 10:02 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1702 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:35:27 UTC

Description cshao 2016-08-08 10:01:56 UTC
Created attachment 1188587 [details]
pre-release

Description of problem:
"Pre-release" page not need anymore in RC phase.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160803.3
imgbased-0.7.4-0.1.el7ev.noarch 

How reproducible:
100%

Steps to Reproduce:
1. Anaconda interactive install RHVH via ISO with default ks.
2. Focus on "pre-release" page. 
3. 

Actual results:
"Pre-release" page appeared in RC phase.

Expected results:
1. "Pre-release" page not need anymore in RC phase.
2. Remove "PRE-RELEASE/TESTING" from anaconda.

Additional info:

Comment 1 cshao 2016-08-08 10:02:30 UTC
Created attachment 1188588 [details]
pre-release2

Comment 3 Fabian Deutsch 2016-08-11 10:44:27 UTC
From

https://gerrit.ovirt.org/gitweb?p=ovirt-node-ng.git;a=blob;f=scripts/create-product-img.sh;h=bd6ec0ff6fadc6b28c72fcad652ec98cb2acbe18;hb=HEAD#l35

IsFinal just needs to be set to True

  30 cat > "$PRDDIR/.buildstamp" <<EOF
  31 [Main]
  32 Product=oVirt Node Next
  33 Version=${VERSION}
  34 BugURL=https://bugzilla.redhat.com
  35 IsFinal=${ISFINAL}

Comment 4 Pavol Babinčák 2016-08-15 13:03:02 UTC
Following up today's RHV devel meeting I'm looking on this bug.

According to current distill configuration for RHEV-H image:
http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/distill_ng/rhvh/rhvh-rhel-7.2.conf?id=df927953022e41ac52781a19c163e6eae47cf1ec#n13

packages are pulled from brew tag *rhevm-4.0-rhel-7-rhevh-compose*. Check for latest packages in that tag:

~❯ brew latest-pkg rhevm-4.0-rhel-7-rhevh-compose redhat-virtualization-host
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
redhat-virtualization-host-4.0-20160812.0  rhevm-4.0-rhel-7-candidate  rbarry
~❯ brew latest-pkg rhevm-4.0-rhel-7-rhevh-compose imgbased                  
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
imgbased-0.8.4-1.el7ev                    rhevm-4.0-rhel-7-candidate  rbarry

both are greater than the required ones.

Now the question is if there is or will be a compose which creates new RC image. I've failed to find that out so I'll leave this on Joey to provide exact build which will be released.

Comment 5 Ryan Barry 2016-08-15 13:15:32 UTC
Right -- Joey is generating a distill now.

However, it would probably be nice if you also knew how to do this.

The other bug we're very curious about is:

https://bugzilla.redhat.com/show_bug.cgi?id=1367042 -- that package should not be in the RHVH channel...

Comment 6 Ryan Barry 2016-08-15 13:15:32 UTC
Right -- Joey is generating a distill now.

However, it would probably be nice if you also knew how to do this.

The other bug we're very curious about is:

https://bugzilla.redhat.com/show_bug.cgi?id=1367042 -- that package should not be in the RHVH channel...

Comment 7 cshao 2016-08-16 07:07:11 UTC
Test version:
RHVH-7.2-20160815.0-RHVH-x86_64-dvd1.iso
imgbased-0.8.4-1.el7ev.noarch

Test steps:
1. Anaconda interactive install RHVH via ISO with default ks.
2. Focus on all installation page. 

Test result:
No "Pre-release" page during anaconda installation, so the bug is fixed, change bug status to VERIFIED.

Comment 9 errata-xmlrpc 2016-08-23 21:08:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1702.html


Note You need to log in before you can comment on or make changes to this bug.