Bug 1364975 - Get PVC show capacity is 0 and access mode as empty.
Summary: Get PVC show capacity is 0 and access mode as empty.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 10:04 UTC by Liang Xia
Modified: 2017-03-08 18:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
this bug was not in any public OpenShift release.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:42:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Liang Xia 2016-08-08 10:04:45 UTC
Description of problem:
Run comand "oc get pvc", the output show capacity is 0,
and access mode is empty.
While command "oc get pvc -o yaml/json" show the correct value.

This is address in https://trello.com/c/B1K0kBKG

Version-Release number of selected component (if applicable):
openshift v3.3.0.16
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

How reproducible:
Always

Steps to Reproduce:
1.Create a PVC.
oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/persistent-volumes/nfs/auto/pvc.json
oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/persistent-volumes/misc/pvc.json
2.Run command "oc get pvc"
3.Run command "oc get pvc -o yaml/json"

Actual results:
In step 2, access mode is empty, capacity is 0.
In step 3, correct value show.

Expected results:
Step 2 show the correct value.

Additional info:
# oc get pvc --all-namespaces
NAMESPACE   NAME                 STATUS    VOLUME                                     CAPACITY   ACCESSMODES   AGE
5ajid       dynamic-pvc1-5ajid   Bound     pvc-c11dfda3-5d48-11e6-877a-0e3642f098ed   0                        15m
5ajid       dynamic-pvc2-5ajid   Bound     pvc-c250c257-5d48-11e6-877a-0e3642f098ed   0                        15m
5ajid       dynamic-pvc3-5ajid   Bound     pvc-c374f9dd-5d48-11e6-877a-0e3642f098ed   0                        15m
default     nfsc                 Pending   nfs                                        0                        10s

Comment 1 Jan Safranek 2016-08-08 13:38:20 UTC
Needs https://github.com/kubernetes/kubernetes/pull/29982, backporting shortly

Comment 2 Jan Safranek 2016-08-08 13:47:52 UTC
Filled https://github.com/openshift/origin/pull/10268

Comment 3 Troy Dawson 2016-08-18 20:33:22 UTC
This has been merged into ose and is in OSE v3.3.0.22 or newer.

Comment 5 Liang Xia 2016-08-19 02:10:21 UTC
Verified the issue has been fixed.

# oc get pvc --all-namespaces
NAMESPACE   NAME                 STATUS    VOLUME                                     CAPACITY   ACCESSMODES   AGE
tcblq       dynamic-pvc1-tcblq   Bound     pvc-d427dd9e-65b0-11e6-9c32-0e01a0b3d827   1Gi        RWO           6m
tcblq       dynamic-pvc2-tcblq   Bound pvc-d7edb345-65b0-11e6-9c32-0e01a0b3d827   2Gi        RWX           6m
tcblq       dynamic-pvc3-tcblq   Bound   pvc-da47a9e0-65b0-11e6-9c32-0e01a0b3d827   3Gi        ROX           6m

# openshift version
openshift v3.3.0.22
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Comment 7 errata-xmlrpc 2016-09-27 09:42:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.