Bug 136504 - missing link to libstdc++ for x86 on IA64
missing link to libstdc++ for x86 on IA64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: compat-libs (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 12:10 EDT by Sreedharamurthy K
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 04:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sreedharamurthy K 2004-10-20 12:10:05 EDT
Description of problem:
OS: RHEL AS,WS,ES 3 Update 3 - IPF

On above version of EL we found a problem with stdc++ library link 
not being present. The c++ library libstdc++-libc6.1-1.so.2 is not 
present on the system. Thus any binary linked to this will fail to 
run. Application linked to this library gives the message:

libstdc++-libc6.1-1.so.2: cannot open shared object file: No such 
file or directory

But the strange thing is 'rpm -q --whatprovides libstdc++-libc6.1-
1.so.2' 
shows that the library is present on the system in 
compat-libstdc++-7.3-2.96.128 package.

#rpm -q --whatprovides libstdc++-libc6.1-1.so.2
compat-libstdc++-7.3-2.96.128

Yes, the library libstdc++-2-libc6.1-1-2.9.0.so exists with the above 
package but the link to the libstdc++-libc6.1-1.so.2 is not present 
which it should be. I believe this is a problem with installation 
scripts.

When I searched the dtabse I found a bug number 111716 which is 
reported on the base release, I guess. This bug has an answer saying 
it is resolved in update 2. But the update 3 this problem still 
exists.

Version-Release number of selected component (if applicable):
7.3-2.96.128

How reproducible:
Run ls command under /emul/ia32-linux/usr/lib/ for the above library.

Steps to Reproduce:
1. cd /emul/ia32-linux/usr/lib/
2. ls libstdc++-libc6.1-1.so.2
3.
  
Actual results:


Expected results:
Link should be present as the actual librtary is different.

Additional info:
Comment 1 Jakub Jelinek 2004-10-20 19:54:08 EDT
Are you sure you have glibc-2.3.2-95.27 or later installed?
The link should be created by ldconfig, which since -95.27 should
walk through /emu/ia32-linux/usr/lib and other directories.
Comment 2 Sreedharamurthy K 2004-10-21 01:28:37 EDT
We have the update 3 CDs for RHEL 3. When we installed we have glibc-
2.3.2-95.24 (got from the rpm query).

Then, why is this package not included in the Update 3 CDs? i.e., ISO 
image of Update 3 does not contain the newer glibc you have 
mentioned. We cannot ask customers to download this separately and 
install on their system. Or how can a subscriber get this package?
Comment 3 Jakub Jelinek 2004-10-21 04:53:30 EDT
AFAIK RHEL3 U3 comes with glibc-2.3.3-95.27.
https://rhn.redhat.com/errata/RHBA-2004-384.html
2.3.2-95.24 could be RHEL3 U3 beta, but certainly not U3 final CD.

If you have this problem with RHEL3 U3 glibc, please reopen.

Note You need to log in before you can comment on or make changes to this bug.