Bug 1365051
| Summary: | Importing VMs from KVM fails when using qemu+tcp libvirt uri | ||
|---|---|---|---|
| Product: | [oVirt] vdsm | Reporter: | nijin ashok <nashok> |
| Component: | General | Assignee: | Francesco Romani <fromani> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Nisim Simsolo <nsimsolo> |
| Severity: | medium | Docs Contact: | |
| Priority: | high | ||
| Version: | 4.18.0 | CC: | bazulay, bugs, emahoney, gklein, lsurette, mgoldboi, michal.skrivanek, nsimsolo, srevivo, tjelinek, ycui, ykaul |
| Target Milestone: | ovirt-4.0.5 | Flags: | rule-engine:
ovirt-4.0.z+
mgoldboi: planning_ack+ michal.skrivanek: devel_ack+ mavital: testing_ack+ |
| Target Release: | 4.18.15 | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2017-01-18 07:36:51 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | Virt | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Proposed a fix upstream https://gerrit.ovirt.org/#/c/62052/ Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone. this is merged only to master, moving back to post patch landed in 4.0 branch -> MODIFIED Verified: ovirt-engine-4.0.5-0.1.el7ev qemu-kvm-rhev-2.6.0-27.el7.x86_64 sanlock-3.4.0-1.el7.x86_64 vdsm-4.18.15-1.el7ev.x86_64 libvirt-client-2.0.0-10.el7.x86_64 |
Description of problem: Importing VMs from KVM to RHEV fails when libvirt uri is using qemu+tcp . This is failing with below error. Thread-124::DEBUG::2016-08-08 03:14:04,426::commands::68::root::(execCmd) /usr/bin/taskset --cpu-list 0-7 /usr/bin/nice -n 19 /usr/bin/ionice -c 3 /usr/libexec/vdsm/kvm2ovirt --uri qemu+tcp://10.65.209.113/system --username nijin --password-file /var/run/vdsm/v2v/03751e96-bc69-410b-b8c5-7df5ca166d6c.tmp --source /images/rhel6.5-template.qcow2 --dest /rhev/data-center/00000001-0001-0001-0001-000000000249/949b8b98-dfe6-428d-8d91-45c11ad32323/images/539fa706-f38e-4713-a4c5-1d8df7cd20aa/732bc9ca-429a-4205-a3cd-1dc7d5ee8626 (cwd None) Thread-124::ERROR::2016-08-08 03:14:14,763::v2v::672::root::(_run) Job u'03751e96-bc69-410b-b8c5-7df5ca166d6c' failed Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/vdsm/v2v.py", line 667, in _run self._import() File "/usr/lib/python2.7/site-packages/vdsm/v2v.py", line 694, in _import self._proc.stderr.read(1024))) V2VProcessError: Job u'03751e96-bc69-410b-b8c5-7df5ca166d6c' process failed exit-code: 1, stderr: Traceback (most recent call last): File "/lib/python2.7/site-packages/vdsm/libvirtconnection.py", line 91, in req cred[4] = passwd.value if passwd else None Listing of VMs from KVM works fine. Also importing using qemu+ssh also works good. Version-Release number of selected component (if applicable): vdsm-4.18.6-1.el7ev.x86_64 How reproducible: 100% Steps to Reproduce: 1. Import the VM with libvirt uri qemu+tcp://ip/system 2. Importing fails with error. Actual results: Importing Vms from KVM with qemu+tcp is not working. Expected results: Importing should work. Additional info: