Bug 136507 - [PATCH] fix URI parsing
Summary: [PATCH] fix URI parsing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-20 16:30 UTC by Ronald Bultje
Modified: 2013-03-13 04:46 UTC (History)
1 user (show)

Fixed In Version: 0.8.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-29 14:50:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Escape/Unescape provided URIs correctly (6.88 KB, patch)
2004-10-20 16:31 UTC, Ronald Bultje
no flags Details | Diff

Description Ronald Bultje 2004-10-20 16:30:09 UTC
Version 0.8.7 has a URI escape parsing bug in its URI interface that
will, in some cases, make GStreamer refuse to open files containing
special characters (such as a space).

Patch attached against the current RPM in Fedora Core Rawhide (0.8.7-3).

Comment 1 Ronald Bultje 2004-10-20 16:31:04 UTC
Created attachment 105518 [details]
Escape/Unescape provided URIs correctly

Comment 2 Colin Walters 2004-10-20 17:00:10 UTC
This escaping code is the same stuff copied from a glib patch, right?  I seem to
remember doing the same for libgnomecups.  You didn't modify the escaping code
in any other way, right?

Comment 3 Need Real Name 2004-10-20 17:24:36 UTC
Colin: No, they are straight copies.

Comment 4 John Thacker 2006-04-29 14:50:54 UTC
This got fixed upstream in 0.8.8 IIRC, and FC4 includes a version past
that.  (FC5 is 0.10.x series)  FC3 and earlier are Fedora Legacy and this
won't get fixed since it's not security.  Closing.


Note You need to log in before you can comment on or make changes to this bug.