Bug 136508 - [PATCH] fix window popup in totem
[PATCH] fix window popup in totem
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 12:33 EDT by Ronald Bultje
Modified: 2013-03-13 00:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 01:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reuse video/audio bins instead of resetting them to NULL (which causes a window popup on loading new media) (16.28 KB, patch)
2004-10-20 12:34 EDT, Ronald Bultje
no flags Details | Diff

  None (edit)
Description Ronald Bultje 2004-10-20 12:33:16 EDT
Totem + GStreamer-plugins 0.8.5 will pop up a new toplevel window for
a split second on startup. This is because of an unneeded state swap
to/from NULL by playbin. Playbin has been modified to reuse the
existing audio/video sinks so this doesn't happen.

Patch attached against current GStreamer-plugins in Rawhide (0.8.5-1).
Comment 1 Ronald Bultje 2004-10-20 12:34:04 EDT
Created attachment 105519 [details]
Reuse video/audio bins instead of resetting them to NULL (which causes a window popup on loading new media)
Comment 2 Colin Walters 2004-10-20 12:59:06 EDT
Hm, this patch seems fairly invasive, but on the other hand nothing we ship
besides Totem is using the playbin/decodebin plugins, so it should be safe.
Comment 3 John Thacker 2006-04-15 15:43:42 EDT
I'm pretty sure this was fixed long ago in gstreamer-plugins.  I certainly don't
see the behavior now in totem.  Can this be closed?
Comment 4 Matthias Clasen 2006-04-19 01:07:42 EDT
yes, lets close it

Note You need to log in before you can comment on or make changes to this bug.