Bug 1365083 - Incomplete output returned for command ipa vault-add
Summary: Incomplete output returned for command ipa vault-add
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 12:21 UTC by Nikhil Dehadrai
Modified: 2016-11-04 06:00 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:00:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Nikhil Dehadrai 2016-08-08 12:21:08 UTC
Description of problem:
Incomplete output returned for command ipa vault-add when run for IPA server configured for RHEL 7.3.

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup RHEL 7.3 
2. Setup IPA server. (In my case IPA version : ipa-server-4.4.0-3.el7.x86_64)
3. Run the command:
# kinit admin (Provide appropriate password)

4. Now run:
# ipa-kra-install -p Secret123 -U

5. Now run:
# ipa vault-add vupgrade --type=symmetric --password='mypa55word'

Actual results:
After step5, following output is displayed:
----------------------
Added vault "vupgrade"
----------------------


Expected results:
After step5, complete information should be displayed


Additional info:
The same command works successfully in IPA configurred on RHEL 7.2.z (In my case 7.2up6)
# ipa vault-add vupgrade --type=symmetric --password='mypa55word'
----------------------
Added vault "vupgrade"
----------------------
  Vault name: vupgrade
  Type: symmetric
  Salt: QW7waLAv8jNZurOgkY1hlw==
  Owner users: admin
  Vault user: admin

Comment 3 Jan Cholasta 2016-08-09 13:57:26 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6182

Comment 4 David Kupka 2016-08-10 08:28:14 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/20ee4a73e7b9e0ccdc7725ff4b87404d5543992e

Comment 6 Nikhil Dehadrai 2016-09-13 10:35:49 UTC
IPA -server version: ipa-server-4.4.0-11.el7.x86_64

Verified the bug on the basis of below points:
1. Verified that ipa-kra-install -p <password> -U is successfully installed on latest version of ipa-server.
2. Verified that when command 'ipa vault-add vupgrade' is run, following complete message details is displayed:

# ipa vault-add vupgrade --type=symmetric --password='mypa55word'
----------------------
Added vault "vupgrade"
----------------------
  Vault name: vupgrade
  Type: symmetric
  Salt: BYa7E+JiLulgmKwQUjw0Mw==
  Owner users: admin
  Vault user: admin

Thus on the basis of above observation marking the status of bug to "VERIFIED".

Comment 8 errata-xmlrpc 2016-11-04 06:00:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.