Bug 1365486 - [RFE] Include support for C.UTF-8 locale in RHEL7
Summary: [RFE] Include support for C.UTF-8 locale in RHEL7
Keywords:
Status: CLOSED DUPLICATE of bug 1361965
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Carlos O'Donell
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On: 902094
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 11:28 UTC by amit yadav
Modified: 2016-09-12 09:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-12 09:22:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2489721 None None None 2016-08-09 12:05:14 UTC
Sourceware 17318 None None None 2019-05-27 15:17:53 UTC

Description amit yadav 2016-08-09 11:28:58 UTC
Description of problem:
Please include support for C.UTF-8 locale in glibc-common available in RHEL7.

Version-Release number of selected component (if applicable):
glibc-common-2.17-106.el7_2.4

Actual results:
Unable to set C.UTF-8 locale in RHEL7

Expected results:
Should be able to set C.UTF-8 locale in RHEL7

Additional info:
Support for  C.UTF-8 locale was included in glibc-common:

$ cat /etc/redhat-release 
Fedora release 23 (Twenty Three)

$ locate C.utf8/usr/lib/locale/C.utf8
/usr/lib/locale/C.utf8/LC_ADDRESS
/usr/lib/locale/C.utf8/LC_COLLATE
/usr/lib/locale/C.utf8/LC_CTYPE
/usr/lib/locale/C.utf8/LC_IDENTIFICATION
/usr/lib/locale/C.utf8/LC_MEASUREMENT
/usr/lib/locale/C.utf8/LC_MESSAGES
/usr/lib/locale/C.utf8/LC_MONETARY
/usr/lib/locale/C.utf8/LC_NAME
/usr/lib/locale/C.utf8/LC_NUMERIC
/usr/lib/locale/C.utf8/LC_PAPER
/usr/lib/locale/C.utf8/LC_TELEPHONE
/usr/lib/locale/C.utf8/LC_TIME
/usr/lib/locale/C.utf8/LC_MESSAGES/SYS_LC_MESSAGES

$ rpm -qf /usr/lib/locale/C.utf8
glibc-common-2.22-17.fc23.x86_64

Reference bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=902094

Comment 3 Florian Weimer 2016-09-12 09:22:59 UTC

*** This bug has been marked as a duplicate of bug 1361965 ***


Note You need to log in before you can comment on or make changes to this bug.