Bug 1365526 - build fails during "make check"
Summary: build fails during "make check"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 12:49 UTC by Jan Cholasta
Modified: 2016-11-04 06:00 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:00:36 UTC


Attachments (Terms of Use)
snip from rpmbuild console output (2.72 KB, text/plain)
2016-09-20 11:41 UTC, Kaleem
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Cholasta 2016-08-09 12:49:40 UTC
Description of problem:

"make check" was temporarily disabled in ipa spec file because it failed with:

make[4]: Entering directory `/builddir/build/BUILD/freeipa-4.4.0/daemons/ipa-kdb'
FAIL: ipa_kdb_tests
make[5]: Entering directory `/builddir/build/BUILD/freeipa-4.4.0/daemons/ipa-kdb'
make[5]: Nothing to be done for `all'.
make[5]: Leaving directory `/builddir/build/BUILD/freeipa-4.4.0/daemons/ipa-kdb'
==============================================
   ipa-server 4.4.0: ipa-kdb/test-suite.log
==============================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
.. contents:: :depth: 2
FAIL: ipa_kdb_tests
===================
[==========] Running 4 test(s).
[ RUN      ] test_get_authz_data_types
Could not run the test - check test fixtures
[  ERROR   ] test_get_authz_data_types
[ RUN      ] test_filter_logon_info
Could not run the test - check test fixtures
[  ERROR   ] test_filter_logon_info
[ RUN      ] test_string_to_sid
[       OK ] test_string_to_sid
[ RUN      ] test_dom_sid_string
Could not run the test - check test fixtures
[  ERROR   ] test_dom_sid_string
[==========] 4 test(s) run.
[  PASSED  ] 1 test(s).
============================================================================
Testsuite summary for ipa-server 4.4.0
============================================================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See ipa-kdb/test-suite.log
Please report to https://hosted.fedoraproject.org/projects/freeipa/newticket
============================================================================
make[4]: Leaving directory `/builddir/build/BUILD/freeipa-4.4.0/daemons/ipa-kdb'

This should be fixed and "make check" enabled again.


Version-Release number of selected component (if applicable):
ipa-4.4.0-1.el7

How reproducible:
Always.

Steps to Reproduce:
1. Try to build ipa packages
2.
3.

Actual results:
The build fails

Expected results:
The build succeeds

Additional info:

Comment 1 Jan Cholasta 2016-08-09 13:01:31 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6173

Comment 2 Jan Cholasta 2016-08-09 13:03:44 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/5fece5ff17fa5c2deead3d44953c512b7060f6ca/

Comment 4 Kaleem 2016-09-20 11:41:06 UTC
Verified.

IPA version:
============
ipa-4.4.0-12.el7.

Please find the attached file which contains snip from rpmbuild console output.

Comment 5 Kaleem 2016-09-20 11:41 UTC
Created attachment 1202865 [details]
snip from rpmbuild console output

Comment 7 errata-xmlrpc 2016-11-04 06:00:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.