Bug 136558 - Xorg comes up without loading radeon drivers
Xorg comes up without loading radeon drivers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 17:39 EDT by Jonathan Zdziarski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 04:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Zdziarski 2004-10-20 17:39:17 EDT
Description of problem:

Every time I boot up Xorg, I wind up with no direct rendering; I have
to rmmod radeon; modprobe radeon, then kill X...which is very annoying
to say the least, especially if you're running gdm like I am.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.1-8

How reproducible:

Every time

Steps to Reproduce:
1.Boot
2.Login
3.glxinfo|grep direct
  
Actual results:

direct rendering: No

Expected results:

direct rendering: Yes

Additional info:
Comment 1 Mike A. Harris 2004-10-20 18:04:25 EDT
Do the following:

rpm -e rhgb

Alternatively you can just disable Red Hat graphical boot.  After
you have done either of these, does DRI now work as expected?
Comment 2 Jonathan Zdziarski 2004-10-20 18:17:01 EDT
I booted up without the rhgb flag, and direct rendering is available
now. Thanks.
Comment 3 Julian Gomez 2004-11-18 03:16:52 EST
On a Dell PowerEdge 2850, installed with RedHat ES3, Update 2 with the
following graphics adapter- Radeon RV100 QY [Radeon 7000/VE], the
installation and redhat-config-xfree86 both correctly detect the
adapter and want to use the 'radeon.o' module.

However, we noticed that X starts up with a maximum resolution of 640
x 480. The problem was that 'radeon.o' was not configured to load
within '/etc/modules.conf'.

Adding 'alias video radeon' or modprobing the module prior to starting
X fixed the issue. The resolution was also much better :)

A bug I presume?

Julian Gomez
Comment 4 Mike A. Harris 2004-11-18 04:00:51 EST
To the original reporter:  This problem was due to a bug in rhgb
which has since been resolved in the final release of Fedora
Core 3, so I'm closing the bug as fixed in the "CURRENTRELEASE".


In response to comment #3, the X11 that ships with Red Hat
Enterprise Linux 3 is completely different, it's XFree86 4.3.0,
whereas Fedora Core 3 ships X.Org X11 6.8.1.  The problem
described in this bug report was due to rhgb starting up one
X server, which then acquires the DRI, then starts up the
second real X server that the user uses before the first X server
terminates.  Since only one X server can use DRI at a time, the
second server is denied DRI support.  We have fixed this problem
by starting the first server with DRI intentionally disabled, as
it is not needed by rhgb.  As such, the real X server should
always get DRI now.

Red Hat Enterprise Linux 3 supports DRI on Radeon VE/7000 hardware
out of the box, with no additional configuration.  If you are using
the official Red Hat supplied kernel, XFree86 and supplied driver
modules, fully updated to the latest official releases, you should
not have to manually configure anything, and should not edit
/etc/modules.conf.  The X server itself loads the kernel modules.

If you are using the official kernel/XFree86, etc. supplied by
Red Hat, and experiencing a problem with RHEL 3 and DRI, it is
recommended to contact Red Hat technical support via one of our
support methods, such as telephone, and provide the details
of the problem.  They will best be able to assist you with
any Red Hat Enterprise Linux related problems.

Note You need to log in before you can comment on or make changes to this bug.