Bug 1365593 - dnf: misleading error message when trying to "upgrade" src.rpm
Summary: dnf: misleading error message when trying to "upgrade" src.rpm
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
low
unspecified
Target Milestone: ---
Assignee: Štěpán Smetana
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Triaged, UserExperience
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 15:51 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2016-10-04 18:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 18:06:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2016-08-09 15:51:20 UTC
Description of problem:
I was installing some rpms using a wildcard, and saw the message
"Package … not installed, cannot update it.", even though the package
was clearly present. It is because dnf warns about the source package
without giving any hint that it is a source package.

Version-Release number of selected component (if applicable):
dnf-1.1.9-2.fc24.noarch

Actual results:
$ sudo dnf upgrade /var/lib/mock/fedora-24-x86_64/result/systemd-229-11.fc24.src.rpm
Package systemd not installed, cannot update it.

Expected results:
$ sudo dnf upgrade /var/lib/mock/fedora-24-x86_64/result/systemd-229-11.fc24.src.rpm
Package /var/lib/mock/fedora-24-x86_64/result/systemd-229-11.fc24.src.rpm is a source package and cannot be updated, ignoring.

Comment 1 Igor Gnatenko 2016-08-09 17:06:16 UTC
totally agree

Comment 2 Štěpán Smetana 2016-08-11 16:05:03 UTC
Created PR: https://github.com/rpm-software-management/dnf/pull/560


Note You need to log in before you can comment on or make changes to this bug.