Bug 1365604 - Mouse hovering on the volume does not display any tool tip
Summary: Mouse hovering on the volume does not display any tool tip
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.0.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.1.0-alpha
: 4.1.0.2
Assignee: Ramesh N
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 16:33 UTC by RamaKasturi
Modified: 2017-02-01 14:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:49:17 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
rnachimu: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 62277 0 master MERGED gluster: fix tool tip issue in VolumeStatusCell 2016-08-16 12:04:29 UTC
oVirt gerrit 62377 0 ovirt-engine-4.0 MERGED gluster: fix tool tip issue in VolumeStatusCell 2016-08-16 12:49:53 UTC

Description RamaKasturi 2016-08-09 16:33:25 UTC
Description of problem:
1) Mouse hovering on the volume where there are unsynced entried present does not display any tool tip .
2) When the bricks in the volume are down, mouse hovering on the volume displays "volume is up, but bricks are down". I do not see that getting displayed either.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.0.1.1-0.1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install HC setup
2. Kill one of the bricks.
3. 

Actual results:
Mouse hovering on the volume does not display any tool tip related to "unsynced entries" plus the tool tip about "volume is up, but one of the brick is down".

Expected results:
Mouse hovering on the volume should display the tool tip related to unsynced entries present in the volume plus the tool tip about the brick status.

Additional info:

Comment 1 Ramesh N 2016-08-12 07:18:55 UTC
There is an issue with Volume Status tooltip. There is no tooltip displayed in any case. Since this is not related self heal, Changing the bug description accordingly.

Comment 2 Red Hat Bugzilla Rules Engine 2016-08-12 07:21:55 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 3 Sandro Bonazzola 2016-12-12 13:55:49 UTC
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.

Comment 4 RamaKasturi 2017-01-24 14:06:35 UTC
verified with build ovirt-engine-4.1.0-0.3.beta2.el7.noarch

I see that when one of the brick goes down at the volume level mouse hovering on the volume shows displays a tool tip which reads  "UP, but one or more bricks are down, Unsynced entries present - needs healing".

Mouse hovering on the brick which is not down shows the status of the brick with no.of unsynced entries present in that brick.

Mouse hovering on brick and volume displays tool tip and works fine with out any issues.


Note You need to log in before you can comment on or make changes to this bug.