Bug 1365650 - Automatic build-on-config-change is effectively useless in GUI
Summary: Automatic build-on-config-change is effectively useless in GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 18:18 UTC by Justin Pierce
Modified: 2016-09-27 09:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:43:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Justin Pierce 2016-08-09 18:18:12 UTC
Description of problem:
The checkbox in Build Config/Edit pane to enable "Automatically build a new image when the build configuration changes" seems effectively useless until this feature is implemented for changes other than build config creation (i.e. if you see it in the GUI, it has already been created and can't be re-triggered). 


How reproducible:
100%

Steps to Reproduce:
1. Edit a buildconfig in the web console
2. Enable "Automatically build a new image when the build configuration changes"
3. Change a value in the buildconfig
4. Save the changes

Actual results:
No build will result.

Expected results:
A build should be triggered based on the option's wording. 

Additional info:
I understand that this is expected at the moment based on the state of the feature; however, exposing the option in the GUI seems like it will only raise questions.

Comment 1 Jessica Forrester 2016-08-10 12:54:49 UTC
Agreed, I opened the same issue on this a couple days ago https://github.com/openshift/origin-web-console/issues/321

Comment 3 Yanping Zhang 2016-08-19 06:10:48 UTC
Checked on OCP v3.3.0.22, on the edit page of a buildconfig, there is no checkbox for enable triggering a build by configuration change now. 
The bug has been fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2016-09-27 09:43:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.