Bug 1365666 - Difficult to scale down *new* deployment in dump loop from web console
Summary: Difficult to scale down *new* deployment in dump loop from web console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 19:28 UTC by Justin Pierce
Modified: 2017-03-08 18:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Add cancel deployment link to the overview page. Reason: The cancel deployment action could be difficult to discover on the deployment details page. Result: Deployments can now be canceled directly from the overview.
Clone Of:
Environment:
Last Closed: 2016-09-27 09:43:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unable to scale down (22.61 KB, image/png)
2016-08-09 20:55 UTC, Justin Pierce
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Justin Pierce 2016-08-09 19:28:53 UTC
Description of problem:
- Create a new deployment config which will result in a pod with a dump loop. 
- Attempt to scale that deployment down to 0 pods.
- The web console prevents you from using the up/down arrow widgets to accomplish this during backoffs (the predominate state during a dump loop). 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Add mysql-ephemeral template to a project.
2. Set "MySQL Database Name" to something fun, like "test; SELECT * FROM Users"
3. Instantiate the template.
4. Wait for the pod to enter a warning state. 
5. Try to scale down the deployment.

Actual results:
I receive a no-smoking mouse cursor when hovering over the down arrow and the scale down operation is not performed. 

Expected results:
I should be able to scale down the RC since I can do so by altering YAML. 

Additional info:
I noticed that if I scaled down using YAML and then scaled back up using the GUI, the web console would then allow me to scale down via the GUI -- even in the warning state. This is why I suggest the issue may only affect newly created deployments.

Comment 1 Samuel Padgett 2016-08-09 20:03:08 UTC
Justin, was the deployment still in progress when you tried to scale? We disable scaling for in progress deployments. I suspect OpenShift was waiting for a readiness probe to pass before completing the deployment.

> I receive a no-smoking mouse cursor when hovering over the down arrow

In our defense, smoking _is_ bad for you.

Comment 2 Justin Pierce 2016-08-09 20:55:09 UTC
Created attachment 1189417 [details]
Unable to scale down

Comment 3 Justin Pierce 2016-08-09 21:01:17 UTC
Samuel, I've attached a screenshot, if it helps. The GUI overview shows the deployment is "In Progress". Clicking to view the underlying deployment# shows it to be Running. 

This "In Progress" state lasts indefinitely in the GUI overview until you take an action to disrupt the deployment (e.g. like scaling down using YAML or canceling the deployment manually). 

> In our defense, smoking _is_ bad for you.

I appreciate your concern ;-)

Comment 4 Samuel Padgett 2016-08-10 12:18:21 UTC
We disabled scaling in progress deployments to address this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1333129

Adding Michail for input. Maybe the right solution is to let users cancel deployments from the overview.

Comment 6 Michail Kargakis 2016-08-15 12:18:45 UTC
At some point in the future we are going to enable scaling running deployments but currently it's not possible due to a backwards-compatibility issue with scaling from older clients.

Is there any use case for scaling down to zero vs using the Recreate strategy? I can't think of any.

Comment 7 Jessica Forrester 2016-08-16 14:01:34 UTC
So we have dealt with the usability problem by letting you cancel the deployment from the overview

Comment 9 XiaochuanWang 2016-08-19 07:17:07 UTC
Verified on oc/openshift 3.3.0.22

"cancel" button works on overview page for cancelling deployment. 

Scale up/down arrows are valid if there is at lease 1 Active deployment When latest deploy is cancelled.
Scale up/down button will be disabled when if the only 1 running deploy cancelled.

Comment 11 errata-xmlrpc 2016-09-27 09:43:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.