Bug 1365696 - NotRegistered error messages on RHEV host. Error :- virtualization.errors.NotRegistered: System ID not found
Summary: NotRegistered error messages on RHEV host. Error :- virtualization.errors.Not...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: 3.6.0
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ovirt-3.6.9
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: Wei Wang
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 23:10 UTC by vaibhav
Modified: 2016-09-26 14:43 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-09-26 14:43:06 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1936 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6.9 2016-09-26 18:37:55 UTC
oVirt gerrit 62201 master MERGED rhn_model: truncate rhn_virtualization cronjob 2016-08-18 17:40 UTC
oVirt gerrit 62874 ovirt-3.6 MERGED rhn_model: truncate rhn_virtualization cronjob 2016-08-26 13:45 UTC

Description vaibhav 2016-08-09 23:10:24 UTC
Description of problem:
After updating RHEV-H host we are receiving error message like "virtualization.errors.NotRegistered: System ID not found".

Version-Release number of selected component (if applicable):
- Red Hat Enterprise Virtualization Hypervisor release 7.2 

How reproducible:
We can register the RHEV-H host, but still we will get error messages like host is not register.

Steps to Reproduce:
1. Install RHEV-H host.
2. Register it to rhn with subscription-manager and attach correct subscription to host.
3. Check for error message like "virtualization.errors.NotRegistered: System ID not found." 

Actual results:
We are receiving error messages for the host which is already register.

Expected results:
No error messages.

Additional info:

Comment 1 vaibhav 2016-08-09 23:25:47 UTC
We referred article :- https://access.redhat.com/solutions/495963

But we can not remove packages from RHEVH, we check for the cron job which checks for the system if its registered or not.

There is one cron job running which is checking system is register or not, As a workaround you need to empty below cron job on the RHEV-H system..
 
  # cd /etc/cron.d/

  # rhn-virtualization.cron            <-- remove everything from this file and make this file empty.

  #  persist rhn-virtualization.cron   <-- Persist the changes with this command.

And issue resolved.

Now if this packages are not important for RHEVH then we can remove this packages from RHEVH system.

Comment 2 Fabian Deutsch 2016-08-10 07:54:38 UTC
The versions were: 20160516.0.el7ev updated to 20160627.3.el7ev.

Comment 3 Wei Wang 2016-08-29 09:05:16 UTC
Test Version:
RHEV-H 7.2-20160826.1.el7ev
ovirt-node-3.6.1-15.0.el7ev.noarch

Test Steps:
1. Install old RHEV-H on the host.
2. Register it to rhn with subscription-manager and attach correct subscription to host.
3. Update RHEV-H to RHEV-H 7.2-20160826.1.el7ev
4. Check the error message like "virtualization.errors.NotRegistered: System ID not found." 


Result:
No error message is displayed.


The bug cannot be reproduced, change the status to VERIFIED.

Comment 4 Wei Wang 2016-08-29 09:32:41 UTC
Update test steps:
1. Install old RHEV-H(20160606.0.el6ev) on the host
2. Register it to rhn with subscription-manager and attach correct subscription to host.
3. Check the /etc/cron.d/rhn-virtualization.cron content
4. Update RHEV-H to RHEV-H 7.2-20160516.0.el7ev
5. Check the /etc/cron.d/rhn-virtualization.cron content is the same with the one in step 3
6. Update RHEV-H to RHEV-H 7.2-20160826.1.el7ev
7. Check the /etc/cron.d/rhn-virtualization.cron content is the same to ones in step 3 and 5
8. Check the error message like "virtualization.errors.NotRegistered: System ID not found."

Comment 5 Wei Wang 2016-08-29 09:34:23 UTC
correct myself
1. Install old RHEV-H(20160505.0.el6ev) on the host

Comment 7 errata-xmlrpc 2016-09-26 14:43:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1936.html


Note You need to log in before you can comment on or make changes to this bug.