This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 1365698 - python3-dnf-plugins-extras-tracer depends on python2-tracer (instead of python3-tracer)
python3-dnf-plugins-extras-tracer depends on python2-tracer (instead of pytho...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras (Show other bugs)
24
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: PYTHON3-PYTHON2
  Show dependency treegraph
 
Reported: 2016-08-09 19:47 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2016-11-30 06:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-30 06:00:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2016-08-09 19:47:51 EDT
Description of problem:
python3-dnf-plugins-extras-tracer pulls in python2-tracer due to dependency on "tracer" instead of "python3-tracer".

Version-Release number of selected component (if applicable):
0.0.12-1.fc23

How reproducible:
Always

Steps to Reproduce:
1. install python3-tracer
2. try removing python2-tracer

Actual results:
dnf wants to remove python3-dnf-plugins-extras-tracer as well.

Expected results:
python3-dnf-plugins-extras-tracer should not depend on python2-tracer
Comment 1 Dominik 'Rathann' Mierzejewski 2016-11-18 07:15:15 EST
Still valid on F24 (0.0.12-3.fc24.noarch). It's been 3 months and this seems like a very simple change, so if there's no action here for another week, I'll fix it myself.
Comment 2 Igor Gnatenko 2016-11-18 13:23:01 EST
(In reply to Dominik 'Rathann' Mierzejewski from comment #1)
> Still valid on F24 (0.0.12-3.fc24.noarch). It's been 3 months and this seems
> like a very simple change, so if there's no action here for another week,
> I'll fix it myself.
Unfortunately it's not trivial to do, in current version we run it through subprocess.

https://github.com/rpm-software-management/dnf-plugins-extras/commit/4a29b1eda1e12faf4a2b19e9ba030098086a21ea

I will try to backport this, but priority is to fix & release dnf-plugins-extras for DNF 2.0

Note You need to log in before you can comment on or make changes to this bug.