Bug 136572 - vim locks up
vim locks up
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 18:34 EDT by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 20:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Sloan 2004-10-20 18:34:08 EDT
Description of problem:

Twice now today while working on documents in vim it has locked up on
me in insert mode.  This has only started happening since the Oct 20th
updates in which we removed the vim-common depend. I think that might
have broken something

Version-Release number of selected component (if applicable):

vim-6.3.030-3

How reproducible:

Most of the time. 

Steps to Reproduce:
1.  vi name_of_file
2.  go in insert mode
3.  sit idle for a while or mess with the file
4. press Esc key
  
Actual results:

Sits in insert mode

Expected results:

To go into command mode

Additional info:
Comment 1 Karsten Hopp 2004-10-20 18:48:36 EDT
??  
vim-enhanced and vim-X11 still depend on vim-X11, the 
vim-minimal<->vim-common dependency has been removed Nov.13,2003. 
The Oct.20 change was to use versioned dependencies, nothing else 
changed.  
If vim-6.3.030-2 worked, it has to be one of the updated libraries or 
a micompilation by the new gcc which caused the lockup. 
 
Do you have a reliable way to reproduce this lockup ? It's next to 
impossible to find and fix this bug without a testcase. 
Comment 2 Karsten Hopp 2004-10-20 18:49:36 EDT
grr... make that 
vim-enhanced and vim-X11 still depend on vim-common.... 
Comment 3 Scott Sloan 2004-10-20 20:21:16 EDT
>This has only started happening since the Oct 20th
>updates in which we removed the vim-common depend.

My bad, I miss read the Rawhide update report

Since I can't reproduce every time, I'll close it and re-open it when
I findout what's causing it.

Note You need to log in before you can comment on or make changes to this bug.