Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Created attachment 1189547[details]
6test1-debug.log with '-v -x'
Description of problem:
virt-v2v add <graphics type='sdl'/> to guest while do conversion with '-i disk', due to guest boot up failed.
Version-Release number of selected component (if applicable):
libvirt-2.0.0-4.el7.x86_64
libguestfs-1.32.7-1.el7.x86_64
virt-v2v-1.32.7-1.el7.x86_64
qemu-kvm-rhev-2.6.0-19.el7.x86_64
How reproducible:
100%
Steps to Reproduce:
1.Convert guest from disk image with option '-i disk'.
# virt-v2v -i disk 6test1.img -os opt
[ 0.0] Opening the source -i disk 6test1.img
[ 0.3] Creating an overlay to protect the source from being modified
[ 0.4] Initializing the target -o libvirt -os opt
[ 0.4] Opening the overlay
[ 5.7] Inspecting the overlay
[ 16.0] Checking for sufficient free disk space in the guest
[ 16.0] Estimating space required on target for each disk
[ 16.0] Converting Red Hat Enterprise Linux Server release 6.8 (Santiago) to run on KVM
virt-v2v: warning: /files/boot/grub/device.map/hd0 references unknown
device "vda". You may have to fix this entry manually after conversion.
virt-v2v: warning: /files/etc/sysconfig/grub/boot references unknown device
"vda". You may have to fix this entry manually after conversion.
virt-v2v: This guest has virtio drivers installed.
[ 65.4] Mapping filesystem data to avoid copying unused and blank areas
[ 65.5] Closing the overlay
[ 65.5] Checking if the guest needs BIOS or UEFI to boot
[ 65.5] Assigning disks to buses
[ 65.5] Copying disk 1/1 to /opt/6test1-sda (raw)
(100.00/100%)
[ 133.7] Creating output metadata
Pool opt refreshed
Domain 6test1 defined from /tmp/v2vlibvirt387543.xml
2.After conversion, boot up guest '6test1'
Actual results:
1. After step2, failed to boot up guest.
# virsh start 6test1
error: Failed to start domain 6test1
error: internal error: process exited while connecting to monitor: qemu-kvm: -sdl: SDL support is disabled
2. Check guest's xml find <graphics type='sdl'/> is added.
Expected results:
While do conversion, should not add sdl graphics to guest.
Additional info:
This is basically what is reported as bug 1372671 -- marking this as duplicate, even if reported before, as bug 1372671 has more discussion.
*** This bug has been marked as a duplicate of bug 1372671 ***
Created attachment 1189547 [details] 6test1-debug.log with '-v -x' Description of problem: virt-v2v add <graphics type='sdl'/> to guest while do conversion with '-i disk', due to guest boot up failed. Version-Release number of selected component (if applicable): libvirt-2.0.0-4.el7.x86_64 libguestfs-1.32.7-1.el7.x86_64 virt-v2v-1.32.7-1.el7.x86_64 qemu-kvm-rhev-2.6.0-19.el7.x86_64 How reproducible: 100% Steps to Reproduce: 1.Convert guest from disk image with option '-i disk'. # virt-v2v -i disk 6test1.img -os opt [ 0.0] Opening the source -i disk 6test1.img [ 0.3] Creating an overlay to protect the source from being modified [ 0.4] Initializing the target -o libvirt -os opt [ 0.4] Opening the overlay [ 5.7] Inspecting the overlay [ 16.0] Checking for sufficient free disk space in the guest [ 16.0] Estimating space required on target for each disk [ 16.0] Converting Red Hat Enterprise Linux Server release 6.8 (Santiago) to run on KVM virt-v2v: warning: /files/boot/grub/device.map/hd0 references unknown device "vda". You may have to fix this entry manually after conversion. virt-v2v: warning: /files/etc/sysconfig/grub/boot references unknown device "vda". You may have to fix this entry manually after conversion. virt-v2v: This guest has virtio drivers installed. [ 65.4] Mapping filesystem data to avoid copying unused and blank areas [ 65.5] Closing the overlay [ 65.5] Checking if the guest needs BIOS or UEFI to boot [ 65.5] Assigning disks to buses [ 65.5] Copying disk 1/1 to /opt/6test1-sda (raw) (100.00/100%) [ 133.7] Creating output metadata Pool opt refreshed Domain 6test1 defined from /tmp/v2vlibvirt387543.xml 2.After conversion, boot up guest '6test1' Actual results: 1. After step2, failed to boot up guest. # virsh start 6test1 error: Failed to start domain 6test1 error: internal error: process exited while connecting to monitor: qemu-kvm: -sdl: SDL support is disabled 2. Check guest's xml find <graphics type='sdl'/> is added. Expected results: While do conversion, should not add sdl graphics to guest. Additional info: