Bug 1365877 - [libgfchangelog]: If changelogs are not available for the requested time range, no proper error message
Summary: [libgfchangelog]: If changelogs are not available for the requested time rang...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: changelog
Version: 3.7.13
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1362151
Blocks: 1364422 1365879
TreeView+ depends on / blocked
 
Reported: 2016-08-10 11:57 UTC by Kotresh HR
Modified: 2016-09-01 09:33 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.15
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1362151
: 1365879 (view as bug list)
Environment:
Last Closed: 2016-09-01 09:21:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2016-08-10 11:57:35 UTC
Description of problem:

 If changelogs are not available for the requested time range, no proper error message is displayed. It just fails. If start time is less than min changelog available time, then history changelog fails with -1 as any failure and no error message is printed. Distinguishing this error will be helpful for 
the consumers to act upon it.

For example, geo-replication upon receiving this error would fallback to
xsync. 

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce: (For simplicity consider plain distribute setup)
This is not simple to reproduce. It might hit during replace brick scencarios.
1. Setup geo-rep between master and slave
2. Before geo-rep syncs all data from master to slave, replace the brick from
   master and write new data on master.
3. Now the replaced brick's min changelog available is much later than the
   stime (sync time) corresponding to this brick.
4. When geo-rep is started after replace brick, it would hit above case.


Actual results:
When start time is less than min available changelog, histor fails with -1 and error is not logged.

Expected results:
It should distinguish the above error, log it and fail.

Comment 1 Vijay Bellur 2016-08-10 12:17:57 UTC
REVIEW: http://review.gluster.org/15139 (features/libgfchangelog: Log failure in gf_histroy_changelog) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)

Comment 2 Vijay Bellur 2016-08-18 13:10:26 UTC
REVIEW: http://review.gluster.org/15139 (features/libgfchangelog: Log failure in gf_histroy_changelog) posted (#2) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)

Comment 3 Vijay Bellur 2016-08-19 06:05:07 UTC
COMMIT: http://review.gluster.org/15139 committed in release-3.7 by Aravinda VK (avishwan@redhat.com) 
------
commit 69ad1ff391a28a9ad5ff40b9eed11ece33c40111
Author: Kotresh HR <khiremat@redhat.com>
Date:   Mon Aug 1 16:59:33 2016 +0530

    features/libgfchangelog: Log failure in gf_histroy_changelog
    
    Add error logs if gf_history_changelog fails. If requested
    changelog range is not available, log the error and exit
    instead of continuing the loop and exiting in readdir
    without logging. Also fixed the duplicate MSGID number in
    'changelog-lib-messages.h'
    
    > Change-Id: Icd71b89ae23b48a71380657ba5649029c32fabfd
    > BUG: 1362151
    > Signed-off-by: Kotresh HR <khiremat@redhat.com>
    > Reviewed-on: http://review.gluster.org/15064
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Aravinda VK <avishwan@redhat.com>
    
    Change-Id: Icd71b89ae23b48a71380657ba5649029c32fabfd
    BUG: 1365877
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/15139
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>

Comment 4 Kaushal 2016-09-01 09:21:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 5 Kaushal 2016-09-01 09:33:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.