Bug 1365913 - Satellite5.6: support more than 13 chars for CVE names
Summary: Satellite5.6: support more than 13 chars for CVE names
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 13:27 UTC by Tomas Lestach
Modified: 2016-09-14 12:05 UTC (History)
6 users (show)

Fixed In Version: satellite-schema-5.6.0.31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-14 12:05:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1866 normal SHIPPED_LIVE Satellite 5.6 bug fix update 2016-09-14 16:01:09 UTC

Description Tomas Lestach 2016-08-10 13:27:43 UTC
Description of problem:
I see Satellite 5.6 still supports only 13 chars for CVE names.

[satellite] (SATELLITE-5.7)$ git diff SATELLITE-5.6 schema/spacewalk/common/tables/rhnCVE.sql
diff --git a/schema/spacewalk/common/tables/rhnCVE.sql b/schema/spacewalk/common/tables/rhnCVE.sql
index 1056841..8a87c30 100644
--- a/schema/spacewalk/common/tables/rhnCVE.sql
+++ b/schema/spacewalk/common/tables/rhnCVE.sql
@@ -19,7 +19,7 @@ CREATE TABLE rhnCVE
     id    NUMBER NOT NULL
               CONSTRAINT rhn_cve_id_pk PRIMARY KEY
               USING INDEX TABLESPACE [[2m_tbs]],
-    name  VARCHAR2(13) NOT NULL
+    name  VARCHAR2(20) NOT NULL
 )
 ENABLE ROW MOVEMENT
 ;


Version-Release number of selected component (if applicable):
Sat 5.6

How reproducible:
always

Steps to Reproduce:
1. Create an erratum with CVE longer than 13 chars

Comment 1 Tomas Lestach 2016-08-10 13:30:45 UTC
So, looking at the upstream code, this has been achieved by at least following three commits ...
spacewalk.git:
 7ebe3a7d542c171af11eb819cd50ca86507a674f
 dcb0e7fda6f79c2c2affee1c21c2a3244797ded7
 e4adb41def454502abcf69e99e49192aab8f766d

Moving to MODIFIED as the fix is available in upstream.

Comment 6 Lukáš Hellebrandt 2016-09-07 13:17:42 UTC
Verified with both satellite-schema-5.6.0.31 and the pre-erratum satellite-schema-5.6.0.29.

After consulting with jdobes and ggainey, it turns out this was never an issue - the problem was on Hosted. The fix in the last commit added is just formal.

Steps taken to verify:
* Sync erratum with CVE longer than 13 chars, check the whole CVE name is present in the Satellite.
* Migrate the satellite to Managed DB from Embedded DB, do the same check.
* Verify that the constant 13 in /etc/sysconfig/rhn/schema-upgrade/satellite-schema-5.6.0.17-to-satellite-schema-5.6.0.18/001-rhnCVE-update.sql.{postgresql,oracle} is changed to 20.

Comment 8 errata-xmlrpc 2016-09-14 12:05:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1866.html


Note You need to log in before you can comment on or make changes to this bug.