Bug 1365952 - Capsule auto-synchronization fails with an error 'PLP0034' (Katello::Errors::PulpError ) after publishing content view on satellite 6.2.0
Summary: Capsule auto-synchronization fails with an error 'PLP0034' (Katello::Errors::...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: 6.2.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: CEE_Sat6_Top_BZs, GSS_Sat6_Top_Bugs
TreeView+ depends on / blocked
 
Reported: 2016-08-10 15:02 UTC by Amar Huchchanavar
Modified: 2019-06-13 21:25 UTC (History)
16 users (show)

Fixed In Version: rubygem-katello-3.0.0.80
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-04 06:44:34 UTC


Attachments (Terms of Use)
hotfix rpm (4.82 MB, application/x-rpm)
2016-09-09 20:12 UTC, Chris Duryee
no flags Details
hotfix for 6.2.2 (5.43 MB, application/x-rpm)
2016-12-06 00:32 UTC, John Mitsch
no flags Details
hotfix for 6.2.2 (ostree) (102.38 KB, application/x-rpm)
2016-12-06 00:33 UTC, John Mitsch
no flags Details
hotfix for 6.2.2 (updated) (4.84 MB, application/x-rpm)
2016-12-13 01:34 UTC, John Mitsch
no flags Details
hotfix for 6.2.2 (ostree, updated) (103.05 KB, application/x-rpm)
2016-12-13 01:36 UTC, John Mitsch
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1993 normal SHIPPED_LIVE Satellite 6.2.2 Async Bug Release 2016-10-04 10:43:20 UTC
Foreman Issue Tracker 16177 None None None 2016-08-18 18:40:30 UTC
Red Hat Knowledge Base (Solution) 2600231 None None None 2016-09-06 14:25:31 UTC

Description Amar Huchchanavar 2016-08-10 15:02:10 UTC
Description of problem:
Since upgrading to Satelite 6.2 from 6.1, when we add a new version of a puppet module, then publish a new content view (and promote it), the puppet repo sync fails to capsule servers (pulp nodes).  The error includes "PLP0034" and "pulp.server.controllers.repository:INFO: duplicate unit names".

~~~
 Error:

Katello::Errors::PulpError

PLP0034: The distributor RedHat-Library-RHEL7Base indicated a failed response when publishing repository RedHat-Library-RHEL7Base. 
~~~

Version-Release number of selected component (if applicable):
Satellite 6.2.0

How reproducible:
Always


Steps to Reproduce:
1.Sync/upload puppet a module with multiple versions.(Eg : motd 1.2.0 and motd 1.2.1)
2.Associate a environment to the capsule.
3.Publish a content view with motd-1.2.0 and promote it to the capsule associated environment. 
4.Let the auto-synchronization complete.
5.Now, add motd 1.2.1 module to the same content view and perform the publish-promote task.
6.This time auto-sync will fail with 'PLP0034' error.

Actual results:
Auto-capsule-sync fails with an error 'PLP0034'

Expected results:
It should not fail and complete the action.

Additional info:
Digging further into the problem, customer found that on the capsule servers that the previous version of the puppet module is still included in the puppet repo to be sync'd, in addition to the new version of the puppet module.  Since there are 2 versions of the same module in the repo, the sync fails.

Comment 3 John Mitsch 2016-08-18 18:38:08 UTC
Created redmine issue http://projects.theforeman.org/issues/16177 from this bug

Comment 5 Bryan Kearney 2016-09-08 18:17:40 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16177 has been resolved.

Comment 6 Chris Duryee 2016-09-09 20:11:17 UTC
hotfix rpm attached as tfm-rubygem-katello-3.0.0.73-1.hotfix.1368746_1365952.el7sat.noarch.rpm (sha1sum 2ced03a29a9c24551dc8dec2ca3a40fd2491b7de)

note: HF package contains fix for this bug and for 1368746 (gofer restart creates applicability regeneration)

to apply:

* rpm -Uvh tfm-rubygem-katello-3.0.0.73-1.hotfix.1368746_1365952.el7sat.noarch.rpm
* katello-service restart

The code change is only needed on the satellite, not capsule

Comment 7 Chris Duryee 2016-09-09 20:12:12 UTC
Created attachment 1199605 [details]
hotfix rpm

Comment 8 Tom McKay 2016-09-12 12:33:43 UTC
Comment on attachment 1199605 [details]
hotfix rpm

Removing private from hotfix rpm

Comment 11 jcallaha 2016-09-30 19:03:05 UTC
Verified in Satellite 6.2.2 Snap 2

After following the steps outlined in the bug report, no issues encountered during capsule sync. The old version of the module was disassociated with the content view and the new one replaced the old throughout the content view and on the capsule's filesystem.

Comment 13 errata-xmlrpc 2016-10-04 06:44:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1993

Comment 14 John Mitsch 2016-12-06 00:32:49 UTC
Created attachment 1228219 [details]
hotfix for 6.2.2

Comment 15 John Mitsch 2016-12-06 00:33:23 UTC
Created attachment 1228220 [details]
hotfix for 6.2.2 (ostree)

Comment 16 John Mitsch 2016-12-13 01:34:43 UTC
Created attachment 1231013 [details]
hotfix for 6.2.2 (updated)

updated, last one was a faulty build

Comment 17 John Mitsch 2016-12-13 01:36:01 UTC
Created attachment 1231014 [details]
hotfix for 6.2.2 (ostree, updated)


Note You need to log in before you can comment on or make changes to this bug.