Bug 136601 - gdmflexiserver not reusing the same virtual terminals with repeated gdmflexiserver usage
gdmflexiserver not reusing the same virtual terminals with repeated gdmflexis...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 01:22 EDT by Jef Spaleta
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-30 22:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2004-10-21 01:22:55 EDT
Description of problem:
login into a regular desktop on vt7
run gdmflexiserver and get a login screen on vt8
close the vt8 login session and you return to vt7 login
run gdmflexiserver again and new login screen gots to vt9
vt8 is not being used for anything.
continued use of gdmflexiserver this way keeps moving the second login
screen to higher and higher vt's

Version-Release number of selected component (if applicable):
gdm-2.6.0.5-5

How reproducible:
always

Steps to Reproduce:
1.login to first desktop vt7
2.run gdmflexiserver and get desktop on vt8, login to second desktop,
logout of second desktop
3. run gdmflexiserver again and get desktop on vt9, logout of vt9
desktop. there is nothing on vt8
4. run gdmflexiserver again and get desktop on vt10. there is nothing
on vt8 or vt9  

Actual results:
virtual terminals not being reused

Expected results:
virtually terminals should be reused.
Comment 1 P Jones 2004-11-21 18:57:36 EST
This looks like the same thing I'm seeing, although I do it this way:
Log in to GNOME, VT7. Drop to VT6 (or lower) doing a Ctrl-Alt-Fn.
Start a new session on VT8 by issuing a startx -- :8 . GNOME comes up
fine. Switch back to VT7 doing a Ctrl-Alt-F7. Switches fine. When
switching back to VT8, all that is there is a flashing line cursor.
Now switch to VT9, and the new session that was on 8 is there.
Comment 2 Jef Spaleta 2005-04-30 22:38:45 EDT
I can no longer reproduce this problem a rawhide box with gdm-2.6.0.8-11.
Repeated calls of gdmflexiserver reuse vt8 as expected.
I'm going to close this ticket as resolution rawhide.

Note You need to log in before you can comment on or make changes to this bug.