Bug 136604 - Sanity check for kernel RPM removal
Sanity check for kernel RPM removal
Status: CLOSED DUPLICATE of bug 136702
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
Brian Brock
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-10-21 01:44 EDT by Daniel McNamara
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel McNamara 2004-10-21 01:44:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
Bug is not to do with program but with humans.

Sometimes it appears we can be astoundingly stupid. In this case I ran
a kernel -e <kernel version> and half way through I reliased this was
the current running version of the kernel. As you can imagine removing
kernel files whilst it's running makes Bad Things(tm) happen.

In any case it struck me that maybe a sanity check could be
implemented in rpm that would basically do:

Does the kernel rpm version I'm being asked to remove match the
current running kernel version? (I assume uname or similar could be
used to compare this)
If so, fail the remove and inform user about this (and possibly that
they need a lot more caffeine)

Provision for this to be overriden with --force to allow forced
removal in case of a spurios match

Just something to catch us when we're being a little stupid.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Be very, very tired or not paying attention
2. rpm -e <kernel version> (where kernel version matches current
running kernel)
3. Watch Bad Things(tm) happen

Actual Results:  Kicked self for stupid act

Expected Results:  Magical running of system with lack of kicking of self

Additional info:
Comment 2 Suzanne Hillman 2004-10-21 15:47:31 EDT
Internal RFE bug #136702 entered; will be considered for future releases.
Comment 5 Ernie Petrides 2004-10-25 17:52:49 EDT

*** This bug has been marked as a duplicate of 136702 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:06:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.