Bug 1366088 - The graphics type changed after migration
Summary: The graphics type changed after migration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: zhe peng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 02:24 UTC by Fangge Jin
Modified: 2017-08-01 23:53 UTC (History)
11 users (show)

Fixed In Version: libvirt-3.2.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 17:11:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1846 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2017-08-01 18:02:50 UTC

Description Fangge Jin 2016-08-11 02:24:31 UTC
Description of problem:
Set graphics listen type to 'socket', start guest and do migration, after migration, the graphics type changed to 'address'.

The live xml before migration:
# virsh dumpxml rhel7.2
...
    <graphics type='vnc' socket='/var/lib/libvirt/qemu/domain-24-rhel7.2/vnc.sock'>
      <listen type='socket' socket='/var/lib/libvirt/qemu/domain-24-rhel7.2/vnc.sock'/>
    </graphics>

The migratable xml is:
# virsh dumpxml rhel7.2 --migratable
...
    <graphics type='vnc'/>

The live xml after migration:
# virsh dumpxml rhel7.2
...
    <graphics type='vnc' port='5900' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>


Version-Release number of selected component:
libvirt-2.0.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set guest graphics type to vnc and listen type to socket
2. Start guest and do migration
3. Check graphics type after migration

Actual results:
After migration, the graphics type changed to 'address'.

Expected results:
After migration, the graphics type doesn't change.

Comment 4 zhe peng 2017-04-25 03:35:34 UTC
I can reproduce this issue.
verify with build:
libvirt-3.2.0-3.el7.x86_64
qemu-kvm-rhev-2.9.0-1.el7.x86_64

step with bug description
after migration, check target guest xml
.....
<graphics type='vnc' socket='/var/lib/libvirt/qemu/domain-8-rhel7/vnc.sock'>
      <listen type='socket' socket='/var/lib/libvirt/qemu/domain-8-rhel7/vnc.sock'/>
    </graphics>
....
additional testing, add --persistent when do migrate, after migration complete,
destroy target guest and check xml:
....
<graphics type='vnc'>
      <listen type='socket'/>
    </graphics>
....
worked as expect, move to verified.

Comment 5 errata-xmlrpc 2017-08-01 17:11:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1846

Comment 6 errata-xmlrpc 2017-08-01 23:53:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1846


Note You need to log in before you can comment on or make changes to this bug.