Bug 136614 - Denials with ntpd
Summary: Denials with ntpd
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-21 07:59 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 09:07:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Gyurdiev 2004-10-21 07:59:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
I *just* relabeled with fixfiles relabel. Launch ntpd - no improvement
to the denies I was getting before relabeling. Time for bugzilla:

[root@cobra ~]# /etc/init.d/ntpd restart
Shutting down ntpd:                                        [  OK  ]
ntpd: Synchronizing with time server:                      [  OK  ]
Starting ntpd:                                             [  OK  ]

[root@cobra ~]# dmesg
audit(1098345278.317:0): avc:  denied  { sendto } for  pid=3498
exe=/usr/sbin/ntpd path=/dev/log scontext=user_u:system_r:ntpd_t
tcontext=user_u:system_r:unconfined_t tclass=unix_dgram_socket
audit(1098345278.611:0): avc:  denied  { write } for  pid=9036
exe=/usr/sbin/ntpdate name=log dev=tmpfs ino=50858
scontext=root:system_r:ntpd_t tcontext=user_u:object_r:device_t
tclass=sock_file
audit(1098345278.611:0): avc:  denied  { sendto } for  pid=9036
exe=/usr/sbin/ntpdate path=/dev/log scontext=root:system_r:ntpd_t
tcontext=user_u:system_r:unconfined_t tclass=unix_dgram_socket
audit(1098345278.626:0): avc:  denied  { search } for  pid=9036
exe=/usr/sbin/ntpdate name=nscd dev=dm-0 ino=146399
scontext=root:system_r:ntpd_t
tcontext=system_u:object_r:nscd_var_run_t tclass=dir

audit2allow:
allow ntpd_t device_t:sock_file { write };
allow ntpd_t nscd_var_run_t:dir { search };
allow ntpd_t unconfined_t:unix_dgram_socket { sendto };

This is running targeted policy in permissive mode.


Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.2

How reproducible:
Always

Steps to Reproduce:
1. See comments


Additional info:

Comment 1 Ivan Gyurdiev 2004-10-21 09:07:33 UTC
Closing - I can't reproduce with the current kernel.
Sorry I was using an old kernel because NVIDIA has been broken 
since .541. It's so unstable too - crashes all the time.


Note You need to log in before you can comment on or make changes to this bug.