Bug 136618 - Ethereal reports wrong checksum on outgoing UDP packets
Summary: Ethereal reports wrong checksum on outgoing UDP packets
Status: CLOSED DUPLICATE of bug 129823
Alias: None
Product: Fedora
Classification: Fedora
Component: tcpdump (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-21 08:25 UTC by Tomas Mraz
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A very simple program to send UDP packets (761 bytes, text/plain)
2004-10-21 08:39 UTC, Tomas Mraz
no flags Details

Description Tomas Mraz 2004-10-21 08:25:16 UTC
Description of problem:
When Ethereal captures outgoing UDP packets it reports a wrong
checksum on them however when I use it to capture the packets on the
receiving side the checksum is OK.

Version-Release number of selected component (if applicable):
0.10.5 from current devel

How reproducible:
Run a program which sends out UDP packets and capture them using Ethereal.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The captured packets have incorrect checksum but in fact they haven't
as verified on receiving side.

Expected results:
The captured packets have correct checksum.

Additional info:
tcpdump seems to capture the packets with right checksum.

Comment 1 Tomas Mraz 2004-10-21 08:38:12 UTC
Sorry for the last info: tcpdump actually captures the packets with
WRONG checksums too. So the problem lies probably in libpcap?


Comment 2 Tomas Mraz 2004-10-21 08:39:30 UTC
Created attachment 105578 [details]
A very simple program to send UDP packets

Change IP address to host you want to send the packets to.

Comment 3 Harald Hoyer 2004-10-21 08:44:01 UTC
which NIC?

Comment 4 Tomas Mraz 2004-10-21 08:50:33 UTC
02:0c.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet
Controller (rev 02)
        Subsystem: Dell Computer Corporation: Unknown device 0151
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 9
        Memory at fcfe0000 (32-bit, non-prefetchable)
        I/O ports at df40 [size=64]
        Capabilities: [dc] Power Management version 2
        Capabilities: [e4] PCI-X non-bridge device.
        Capabilities: [f0] Message Signalled Interrupts: 64bit+
Queue=0/0 Enable-

libpcap version 0.8.3, kernel 2.6.8-1.610


Comment 5 Harald Hoyer 2004-10-21 08:53:22 UTC
some network cards compute the checksum on their own..
maybe a dup of bug #129823

Comment 6 Harald Hoyer 2004-10-21 08:54:37 UTC
Oh, same NIC... 

*** This bug has been marked as a duplicate of 129823 ***

Comment 7 Radek Vokal 2004-10-22 07:30:38 UTC
This is described by ethereal developers -
http://www.ethereal.com/faq#q5.14

Comment 8 Red Hat Bugzilla 2006-02-21 19:06:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.