Bug 1366217 - sound doesn't work after updated to kernel-4.6.5-200.fc23.x86_64
Summary: sound doesn't work after updated to kernel-4.6.5-200.fc23.x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 10:08 UTC by han pingtian
Modified: 2016-09-25 19:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-25 19:29:18 UTC
Type: Bug


Attachments (Terms of Use)
outputs of "alsa-info.sh --no-upload" under 4.6.5-200.fc23.x86_64 (18.29 KB, text/plain)
2016-08-11 10:08 UTC, han pingtian
no flags Details
outputs of "alsa-info.sh --no-upload" under 4.6.4-201.fc23.x86_64 (38.24 KB, text/plain)
2016-08-11 10:09 UTC, han pingtian
no flags Details
outputs of "alsa-info.sh --no-upload" under 4.6.6-200.fc23.x86_64 (18.39 KB, text/plain)
2016-08-12 09:14 UTC, han pingtian
no flags Details

Description han pingtian 2016-08-11 10:08:34 UTC
Created attachment 1190003 [details]
outputs of "alsa-info.sh --no-upload" under 4.6.5-200.fc23.x86_64

Description of problem:
Sound works just fine with kernel-4.6.4-201.fc23.x86_64, but it doesn't work with kernel-4.6.5-200.fc23.x86_64 on my thinkpad p50.


Version-Release number of selected component (if applicable):
kernel-4.6.5-200.fc23.x86_64


How reproducible:
always


Steps to Reproduce:
1. update to kernel-4.6.5-200.fc23.x86_64 on thinkpad p50
2.
3.

Actual results:
after the update, sound doesn't work


Expected results:
sound works


Additional info:

Comment 1 han pingtian 2016-08-11 10:09:53 UTC
Created attachment 1190004 [details]
outputs of "alsa-info.sh --no-upload" under 4.6.4-201.fc23.x86_64

sound works fine with 4.6.4-201.fc23.x86_64.

Comment 2 Laura Abbott 2016-08-11 14:01:05 UTC
Please test https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b67f775fe, this build drops a patch that was linked to issues

Comment 3 han pingtian 2016-08-12 09:14:07 UTC
(In reply to Laura Abbott from comment #2)
> Please test https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b67f775fe,
> this build drops a patch that was linked to issues

I have installed 4.6.6-200.fc23.x86_64, but sound still doesn't work.

Comment 4 han pingtian 2016-08-12 09:14:55 UTC
Created attachment 1190319 [details]
outputs of "alsa-info.sh --no-upload" under 4.6.6-200.fc23.x86_64

Comment 5 Laura Abbott 2016-08-12 17:59:48 UTC
It turns out the patch was dropped in F24 but not F23. I committed it to the F23 branch. I'm not going to respin the 4.6.6 build but it will show up in a build next week, either as an incremental build or as part of 4.6.7 depending on how the stable releases go.

Comment 6 han pingtian 2016-08-24 11:36:15 UTC
This bug has been fixed with  4.6.7-200.fc23.x86_64. Thanks!

Comment 7 Laura Abbott 2016-09-23 19:53:54 UTC
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.

Comment 8 han pingtian 2016-09-24 01:14:30 UTC
This bug has been fixed. Thanks. Please see previous comment 6.

Comment 9 Josh Boyer 2016-09-25 19:29:18 UTC
Thank you.


Note You need to log in before you can comment on or make changes to this bug.