Bug 1366223 - Pipeline build, started before Jenkins is deployed, gets deleted
Summary: Pipeline build, started before Jenkins is deployed, gets deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Jimmi Dyson
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 10:15 UTC by XiuJuan Wang
Modified: 2016-09-27 09:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:43:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description XiuJuan Wang 2016-08-11 10:15:42 UTC
Description of problem:
Could trigger sample-pipeline build successfully before jenkins master pod is ready.Build disappear after the jenkins pod ready, but bc is marked build version to 1.

Version-Release number of selected component (if applicable):
jenkins-1-rhel7 (91cc89832f5f)

How reproducible:
always

Steps to Reproduce:
1.Create a jenkinspipeline app
oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.json
2.Trigger sample-pipeline build before jenkins master is ready
3.

Actual results:
Trigger build successfully, but disappers after jenkins master ready.

Expected results:
Should prompt warning info.

Additional info:

Comment 1 Ben Parees 2016-08-11 15:25:00 UTC
The real issue here is that the build is disappearing, that should not happen, it should be run correctly.  This issue was also reported here:
https://github.com/openshift/jenkins/issues/139

Comment 2 Jimmi Dyson 2016-08-12 10:37:06 UTC
Fixed in https://github.com/jenkinsci/openshift-sync-plugin/pull/7. Releasing community version,

Comment 5 Dongbo Yan 2016-08-22 05:44:43 UTC
Test with 
openshift3/jenkins-1-rhel7       1.651.2-16          19bc08e9d803        2 days ago          626.7 MB
openshift3/jenkins-1-rhel7       latest              19bc08e9d803

this bug is fixed, openshift sync plugin is 0.0.12

Comment 6 Troy Dawson 2016-09-01 15:33:33 UTC
The fix is in jenkins-plugin-openshift-sync-0.0.12-1.el7, which is in openshift3/jenkins-1-rhel7:1.651.2-21 or later.

Comment 9 errata-xmlrpc 2016-09-27 09:43:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.