Bug 1366224 - Recent 4.8 kernels do not read keyboard for entering disk password
Summary: Recent 4.8 kernels do not read keyboard for entering disk password
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F25AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-08-11 10:22 UTC by Bruno Wolff III
Modified: 2016-08-29 06:55 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-29 06:55:27 UTC
Type: ---


Attachments (Terms of Use)
lshw output for the affected machine (20.64 KB, text/plain)
2016-08-15 08:41 UTC, Bruno Wolff III
no flags Details

Description Bruno Wolff III 2016-08-11 10:22:00 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0
Build Identifier: 

I run rawhide nodebug kernels on f24 on a couple of machines. The desktop works normally, but the laptop can't complete booting on recent rawhide nodebug kernels because when I try to enter the disk luks password nothing gets echo'd and enter doesn't have any affect. kernel-PAE-core-4.8.0-0.rc0.git2.2.fc26.i686 works, kernel-PAE-core-4.8.0-0.rc1.git0.1.fc26.i686 and kernel-PAE-core-4.8.0-0.rc1.git1.2.fc26.i686 don't.

Reproducible: Always

Comment 1 Bruno Wolff III 2016-08-12 11:35:45 UTC
kernel-PAE-core-4.8.0-0.rc0.git7.1.fc26.i686 works. A vanilla upstream kernel as of yesterday, didn't. I'll try bisecting between 4.8.0-0.rc0.git7 and rc1. The way these normally go there will probably be an upstream fix before I finish the bisect. (4.8.0-0.rc1.git3.2.fc26 didn't work either.)

Comment 2 Bruno Wolff III 2016-08-15 00:00:54 UTC
git bisect start
# bad: [29b4817d4018df78086157ea3a55c1d9424a7cfc] Linux 4.8-rc1
git bisect bad 29b4817d4018df78086157ea3a55c1d9424a7cfc
# good: [dd7fd3a82ce55e5772d41b1faa2439f15318a902] ACPI / hotplug / PCI: Runtime resume bridges before bus rescans
git bisect good dd7fd3a82ce55e5772d41b1faa2439f15318a902
# bad: [a157b3aaa44829998d5a079174df989e5d8c20ff] Merge tag 'pwm/for-4.8-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/thierry.reding/linux-pwm
git bisect bad a157b3aaa44829998d5a079174df989e5d8c20ff
# good: [f72035fad84c9b51a45fd8afc8024f3df0ba8848] Merge tag 'usb-4.8-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usb
git bisect good f72035fad84c9b51a45fd8afc8024f3df0ba8848
# bad: [a02040d8d5d533773f98e02e1a8e56db5fa7a363] Merge tag 'pstore-v4.8-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/kees/linux
git bisect bad a02040d8d5d533773f98e02e1a8e56db5fa7a363
# bad: [62e6e9bab3014e3931ffbc82de7a9d2fd94cb8cd] Merge tag 'pnp-extra-4.8-rc1' of git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm
git bisect bad 62e6e9bab3014e3931ffbc82de7a9d2fd94cb8cd
# bad: [22fe874f380336315dd0440dad475ff326784b22] Input: silead - remove some dead code
git bisect bad 22fe874f380336315dd0440dad475ff326784b22
# bad: [014420fe8865e981331024ef0cef14d1e29102a3] Input: elantech - fix debug dump of the current packet
git bisect bad 014420fe8865e981331024ef0cef14d1e29102a3
# bad: [4097461897df91041382ff6fcd2bfa7ee6b2448c] Input: i8042 - break load dependency between atkbd/psmouse and i8042
git bisect bad 4097461897df91041382ff6fcd2bfa7ee6b2448c
# good: [887ec0bfbd146c08e34ccb65a8f4251dc110e52f] Input: synaptics-rmi4 - do not check for NULL when calling of_node_put()
git bisect good 887ec0bfbd146c08e34ccb65a8f4251dc110e52f
# first bad commit: [4097461897df91041382ff6fcd2bfa7ee6b2448c] Input: i8042 - break load dependency between atkbd/psmouse and i8042

Comment 3 Bruno Wolff III 2016-08-15 08:14:28 UTC
I tested reverting 4097461897df91041382ff6fcd2bfa7ee6b2448c from a more recent upstream kernel (118253a593bd1c57de2d1193df1ccffe1abe745b) and the keyboard worked. I'm going to test 118253a593bd1c57de2d1193df1ccffe1abe745b to try to confirm this wasn't fix upstream in a different way recently.

Comment 4 Bruno Wolff III 2016-08-15 08:41:06 UTC
Created attachment 1190818 [details]
lshw output for the affected machine

Comment 5 Bruno Wolff III 2016-08-15 09:02:15 UTC
My keyboard doesn't work with 118253a593bd1c57de2d1193df1ccffe1abe745b, so it looks like 4097461897df91041382ff6fcd2bfa7ee6b2448c is the problem. I'll report this upstream later today.

Comment 6 Bruno Wolff III 2016-08-15 14:20:41 UTC
I have filed https://bugzilla.kernel.org/show_bug.cgi?id=153151 upstream and probably we can handle this through that bug. If I don't get any response from that bug, I'll try contacting one or two of the kernel lists.

Comment 7 Bruno Wolff III 2016-08-16 12:49:40 UTC
I have gotten a response from upstream, but so far the suggested fixes haven't helped.

Comment 8 Bruno Wolff III 2016-08-17 11:54:48 UTC
So it turns out my initial "help" was from a clueless kernel groupie, but eventually the person who authored the problem commit showed up and provided a patch that fixed my issue. So I expect that fix will be showing up in Linus' tree in the next few days.

Comment 9 Bruno Wolff III 2016-08-17 18:40:43 UTC
The upstream bug is now closed "code fix" and the fix will be sent to Linus.

Comment 10 Bruno Wolff III 2016-08-22 00:20:35 UTC
The patch is now in Dmitry Torokhov's tree, but didn't make rc3. Dmitry also gave Greg a heads up and pointer to the fix, since the problem commit had been queued for stable. I don't know if they are going to get delayed or not, but both should go in at the same time.

Comment 11 Bruno Wolff III 2016-08-22 16:09:36 UTC
The fix is at:
http://git.kernel.org/cgit/linux/kernel/git/dtor/input.git/commit/?h=for-linus&id=47af45d684b5f3ae000ad448db02ce4f13f73273
Which is in Dmitry's for-linus branch.

Comment 12 Geoffrey Marr 2016-08-22 21:52:36 UTC
Discussed during the 2016-08-22 blocker review meeting: [1]

The decision to classify this as an Alpha AcceptedFreezeException was made as the bug itself is rather serious while the fix is fairly small. For this reason, this bug is being classified as an AcceptedFreezeException.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-22/f25-blocker-review.2016-08-22-16.00.txt

Comment 13 Bruno Wolff III 2016-08-25 19:33:51 UTC
Dmitry has submitted a pull request to Linus for the fix: https://lkml.org/lkml/2016/8/25/512

Comment 14 Bruno Wolff III 2016-08-27 05:09:23 UTC
The fix is in Linus' tree and should be picked up when you build an rc4 kernel on Monday.
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=47af45d684b5f3ae000ad448db02ce4f13f73273

Comment 15 Bruno Wolff III 2016-08-29 00:19:30 UTC
I missed that this got pulled in as a one off fix in advance of getting into Linus' tree. The fix did make into alpha (at least the games spin) and fixes the problem.

Comment 16 Kamil Páral 2016-08-29 06:55:27 UTC
OK, if it made into Alpha (Games Lab should have the same kernel as everything else), let's close this and remove the common bug.


Note You need to log in before you can comment on or make changes to this bug.