Bug 136626 - hald gives timeout message every second
hald gives timeout message every second
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 06:31 EDT by Ralf Ertzinger
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.4.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 16:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output (49.67 KB, text/plain)
2004-10-22 06:26 EDT, Ralf Ertzinger
no flags Details
debugging output (150.51 KB, text/plain)
2004-10-22 06:27 EDT, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2004-10-21 06:31:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Every second hald writes a line similar to the following to syslog:

hald[9382]: Timed out waiting for hotplug event 386

The numbers increase for every line. For most of these lines there is
no according hotplug event recorded in the syslog file. The first
occurance is this pair (triggered by system startup)

Oct 21 12:21:03 nausicaa default.hotplug[9914]: arguments (vc) env
(OLDPWD=/ DEVPATH=/class/vc/vcs6 PATH=/bin:/sbin:/usr/sbin:/usr/b
in ACTION=add PWD=/etc/hotplug HOME=/ SHLVL=2 SEQNUM=298 _=/bin/env)
Oct 21 12:21:05 nausicaa hald[9382]: Timed out waiting for hotplug
event 298

After this a hald line is recorded every second.

Restarting the haldaemon service takes care of the problem.

Version-Release number of selected component (if applicable):
hal-0.4.0-5

How reproducible:
Always

Steps to Reproduce:
1. Boot system, observe syslog
2.
3.
    

Actual Results:  hald records timeout events every second

Expected Results:  No timeouts? At least I did not get them earlier.

Additional info:
Comment 1 David Zeuthen 2004-10-21 15:31:52 EDT
Hmm; this looks difficult to reproduce; a few questions/requests:

1. I suppose disabling the hal daemon and running 'hald --daemon=no
--verbose=yes' wont give the timeouts? If it does, please attach the
output to this bug report

2. Please attach the output lshal

3. Do you have hardware using the prism54 driver? (See bug 135202)

4. Does the hald work as expected when emitting these messages?

5. Will plugging in a USB device stop the emission of these messages?

So, basically I'm looking for a way to get the debug output from the
hal daemon when this happens. One way is to modify your
/etc/init.d/haldaemon init script, e.g. temporarily change this line

 daemon --check $servicename $processname

to this

 /usr/sbin/hald --daemon=no --verbose=yes 2> /tmp/hald_output &

and reboot. Then attach /tmp/hald_output (remember to change it back).

Thanks,
David

Comment 2 Ralf Ertzinger 2004-10-22 05:30:18 EDT
How do I determine if the hal daemon "works as expected"?
Comment 3 Ralf Ertzinger 2004-10-22 06:25:40 EDT
OK, all this seems to be subject to some timing issue.

a) If I disable hal via chkconfig and start the daemon manually after
the system has finished booting, the effect does not occur (this might
explain why restarting the daemon fixes it)

b) Booting with a CD in a CD drive causes the effect to disappear.

c) Plugging in USB devices does not fix it.

d) I do not have any wireless stuff in this machine.

e) hal adds devices to /etc/fstab in any case, so I think it works.

f) I was able to capture the error in debugging mode, output is attached.
Comment 4 Ralf Ertzinger 2004-10-22 06:26:28 EDT
Created attachment 105640 [details]
lshal output
Comment 5 Ralf Ertzinger 2004-10-22 06:27:05 EDT
Created attachment 105641 [details]
debugging output
Comment 6 David Zeuthen 2004-10-22 13:12:04 EDT
Thanks for the traces; please try the RPMS here

 http://people.redhat.com/davidz/hal_test1/

and see if the problem is solved.

Thanks,
David
Comment 7 Ralf Ertzinger 2004-10-26 06:51:30 EDT
hal-0.4.0-5b seems to fix it.
Comment 8 David Zeuthen 2004-10-26 16:03:39 EDT
Thanks, this fix is in hal-0.4.0-8 available here

 http://people.redhat.com/davidz/dist/

which will hopefully make FC3.

Note You need to log in before you can comment on or make changes to this bug.