Bug 1366297 - New Package: python-os-vif - A library for plugging and unplugging virtual interfaces in OpenStack.
Summary: New Package: python-os-vif - A library for plugging and unplugging virtual in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-os-vif
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: beta
: 10.0 (Newton)
Assignee: Jon Schlueter
QA Contact: Thierry Vignaud
URL:
Whiteboard:
Depends On: 1366279
Blocks: RDO-NEWTON
TreeView+ depends on / blocked
 
Reported: 2016-08-11 14:29 UTC by Mike Burns
Modified: 2016-12-14 15:51 UTC (History)
10 users (show)

Fixed In Version: python-os-vif-1.1.0-0.20160811173527.c16a74b.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1366279
Environment:
Last Closed: 2016-12-14 15:51:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Mike Burns 2016-08-11 14:29:20 UTC
+++ This bug was initially created as a clone of Bug #1366279 +++

Description: A library for plugging and unplugging virtual interfaces in OpenStack. It has been introduced as dependency for nova in  https://review.openstack.org/#/c/350595/.

SPEC: https://raw.githubusercontent.com/amoralej/python-os-vif/master/python-os-vif.spec
SRPM: https://github.com/amoralej/python-os-vif/raw/master/python-os-vif-1.1.0-1.el7.centos.src.rpm

I've created a successfull build in copr https://copr.fedorainfracloud.org/coprs/amoralej/python-os-vif/build/440492/

--- Additional comment from David Moreau Simard on 2016-08-11 10:02:00 EDT ---

Some comments:
https://github.com/amoralej/python-os-vif/blob/49208a1289b0f31153d055617a332f5c9a89edce/python-os-vif.spec#L54

Can you add the actual description ?
"A library for plugging and unplugging virtual interfaces in OpenStack."

https://github.com/amoralej/python-os-vif/blob/49208a1289b0f31153d055617a332f5c9a89edce/python-os-vif.spec#L58

I think the tests package should have some additional requires based on the test-requirements.txt: https://github.com/openstack/os-vif/blob/master/test-requirements.txt

Also note that building this package requires packages that aren't in fedora yet (or at least, not at the right required versions), please let us know how we can reproduce the build.

Comment 6 errata-xmlrpc 2016-12-14 15:51:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.