Bug 1366513 - kdump doesn't handle DEV_ID properly for the network interface mapping cases
Summary: kdump doesn't handle DEV_ID properly for the network interface mapping cases
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools
Version: 6.9
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Xunlei Pang
QA Contact: Emma Wu
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 07:45 UTC by Xunlei Pang
Modified: 2018-05-18 05:09 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-03-21 09:12:50 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0584 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2017-03-21 12:24:25 UTC

Description Xunlei Pang 2016-08-12 07:45:17 UTC
Description of problem:
On system with multiple network interfaces, if kdump does the interface mapping,
it will throw:
cat: can't open '/sys/class/net/eth1/dev_id': No such file or directory

Actually there's only eth0 in kdump kernel, eth1 is the old interface in the first kernel.

Normally, this has no problem, but for multiport network card with no "HWADDR" directive specified in ifcfg files, it will rely on DEV_ID to do the matching, and thus problematic.

Version-Release number of selected component (if applicable):
Release 2.0.0-300

How reproducible:


Steps to Reproduce:
1. Using system with multiple network cards installed.
2. Configure to use network dumping via eth1 for example
3. rebuild initramfs and trigger a crash

Actual results:
cat: can't open '/sys/class/net/eth1/dev_id': No such file or directory

Expected results:
No warning printed, and the network dumping can work properly.

Additional info:

Comment 14 errata-xmlrpc 2017-03-21 09:12:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0584.html


Note You need to log in before you can comment on or make changes to this bug.