Bug 1366612 - Middle replica uninstallation in line topology works without '--ignore-topology-disconnect'
Summary: Middle replica uninstallation in line topology works without '--ignore-topolo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On: 1376723
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 12:46 UTC by Petr Vobornik
Modified: 2016-11-04 06:00 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:00:57 UTC


Attachments (Terms of Use)
console.log (2.38 KB, text/plain)
2016-09-20 05:16 UTC, Abhijeet Kasurde
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-08-12 12:46:39 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6168

I was able to uninstall the middle replica in line topology using 'ipa-server-install --uninstall' without specifying '--ignore-topology-disconnect'. [[BR]]
Topology looks like this:
master <-> replica1 <-> replica2

Replica1 was uninstalled successfully.
After replica uninstallation, the output of 'ipa topologysegment-find domain' did not change and looked like:
{{{
------------------
2 segments matched
------------------
  Segment name: replica2-to-replica1
  Left node: replica2
  Right node: replica1
  Connectivity: both

  Segment name: master-to-replica1
  Left node: master
  Right node: replica1
  Connectivity: both
----------------------------
Number of entries returned 2
----------------------------
}}}

The version of the freeipa packages is 4.4.0.201607260719GIT648b5af-0.fc24.x86_64

Expected behavior:

Uninstallation should fail and an error message should be displayed:
"Uninstallation leads to disconnected topology"

Comment 1 Petr Vobornik 2016-08-12 12:48:11 UTC
Related to replica promotion and topology management RFEs

Comment 2 Martin Babinsky 2016-08-17 12:59:43 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/fea56fefff48b0d8eb147c2c2c511c869a1eadf0

Comment 4 Abhijeet Kasurde 2016-09-20 05:15:53 UTC
Verified using IPA version::
ipa-server-4.4.0-12.el7.x86_64

Marking BZ as verified.

Comment 5 Abhijeet Kasurde 2016-09-20 05:16:15 UTC
Created attachment 1202692 [details]
console.log

Comment 7 errata-xmlrpc 2016-11-04 06:00:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.