Bug 1366624 - dnf install python3-sphinx pulls in python2-sphinx
Summary: dnf install python3-sphinx pulls in python2-sphinx
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-sphinx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3-PYTHON2
TreeView+ depends on / blocked
 
Reported: 2016-08-12 13:12 UTC by Igor Gnatenko
Modified: 2016-08-27 10:35 UTC (History)
3 users (show)

Fixed In Version: python-sphinx-1.4.5-1.fc24 python-sphinx-1.4.5-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-21 23:22:13 UTC


Attachments (Terms of Use)
libsolv's debugdata (6.44 MB, application/x-xz)
2016-08-12 13:21 UTC, Igor Gnatenko
no flags Details

Description Igor Gnatenko 2016-08-12 13:12:56 UTC
[brain@x1carbon debugdata]$ sudo dnf -q repoquery --requires python3-sphinx
/usr/bin/python3
graphviz
python(abi) = 3.5
python-sphinx-locale = 1.4.4-2.fc25
python3-babel
python3-docutils
python3-imagesize
python3-jinja2
python3-mock
python3-pygments
python3-six
python3-snowballstemmer
python3-sphinx-theme-alabaster
python3-sphinx_rtd_theme
[brain@x1carbon debugdata]$ sudo dnf -q repoquery --requires python-sphinx-locale
python(Sphinx) = 1.4.4-2.fc25
[brain@x1carbon debugdata]$ sudo dnf -q repoquery --whatprovides "python(Sphinx)"
python2-sphinx-0:1.4.4-2.fc25.noarch
python3-sphinx-0:1.4.4-2.fc25.noarch

It looks like some circular dependency chain, but I don't know all reasons behind.

Comment 1 Igor Gnatenko 2016-08-12 13:21:40 UTC
Created attachment 1190402 [details]
libsolv's debugdata

Comment 2 Avram Lubkin 2016-08-12 13:51:15 UTC
This is actually caused by DFS's handling of Recommends, which seems to be ignoring what's provided by what is being installed. That said, there's really no reason for the locale package to require the python package. I think that was really just in there so it got removed on an uninstall since weak dependencies weren't working well for that.

There's a new version of Sphinx I've been meaning to release, so I'll take out the locale dependencies when I do that.

Comment 3 Fedora Update System 2016-08-12 19:39:16 UTC
python-sphinx-1.4.5-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8856ce7a2d

Comment 4 Fedora Update System 2016-08-12 19:42:05 UTC
python-sphinx-1.4.5-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0365a31f5c

Comment 5 Fedora Update System 2016-08-12 22:52:24 UTC
python-sphinx-1.4.5-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0365a31f5c

Comment 6 Fedora Update System 2016-08-14 00:22:17 UTC
python-sphinx-1.4.5-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8856ce7a2d

Comment 7 Fedora Update System 2016-08-21 23:22:03 UTC
python-sphinx-1.4.5-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-08-27 10:35:02 UTC
python-sphinx-1.4.5-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.