Bug 1366626 - caacl-add-service: incorrect error message when service does not exists
Summary: caacl-add-service: incorrect error message when service does not exists
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-12 13:17 UTC by Petr Vobornik
Modified: 2016-11-04 06:01 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:01:02 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-08-12 13:17:53 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6171


I used steps from #6146

{{{
[root@vm-012 ~]#  ipa caacl-add-service test_caacl --services svc/master2.ipa.test --services svc/master1.ipa.test
  ACL name: test_caacl
  Description: test caacl
  Enabled: TRUE
  Hosts: master2.ipa.test
  Services: svc/master1.ipa.test@ABC.IDM.LAB.ENG.BRQ.REDHAT.COM
  Failed service/service groups: 
    member service: s: no such entry  <--------- *here*

}}}

There is not service ''s'' in options

Output from httpd_err log:
{{{
caacl_add_service/1(u'test_caacl', version=u'2.211', service=(u'svc/master2.ipa.test', u'svc/master1.ipa.test')): SUCCESS
}}}

It looks that client sent correct data, so this is somehow broken on server side

Comment 1 Petr Vobornik 2016-08-12 13:19:30 UTC
Minor regression introduced by bug 1224057

Fixed upstream: https://fedorahosted.org/freeipa/changeset/af4ebaca6293779ef686c7bacffbc97945ebee95/

Comment 4 Scott Poore 2016-09-10 01:56:50 UTC
Verified.

Version ::

ipa-server-4.4.0-9.el7.x86_64

Results ::

[root@master ~]# ipa caacl-add test_caacl
-------------------------
Added CA ACL "test_caacl"
-------------------------
  ACL name: test_caacl
  Enabled: TRUE

[root@master ~]# ipa caacl-add-service test_caacl --services test/$(hostname)
  ACL name: test_caacl
  Enabled: TRUE
  Failed service/service groups: 
    member service: test/master.ipa.test@IPA.TEST: no such entry
-------------------------
Number of members added 0
-------------------------

Comment 6 errata-xmlrpc 2016-11-04 06:01:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.