Bug 136664 - Build absent on PPC
Summary: Build absent on PPC
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: numactl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 135876
TreeView+ depends on / blocked
 
Reported: 2004-10-21 15:30 UTC by David Woodhouse
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 11:04:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2004-10-21 15:30:48 UTC
numactl isn't built on ppc. It needs to be.

Comment 1 Dave Jones 2004-10-27 04:47:24 UTC
puzzled.
ExcludeArch contains ppc64, but the changelog shows you added ppc support.
What gives ?


Comment 2 David Woodhouse 2004-10-27 09:29:48 UTC
ExcludeArch used to contain both ppc64 and ppc. Now it contains only
ppc64. It's the ppc32 version I wanted built -- and it builds fine;
it's just the the other architectures don't build (and didn't before).

We run mostly ppc32 binaries on ppc64. It's not like x86_64 where you
have to use the new ABI just to get a sane number of registers even if
64-bit stuff buys you nothing. 

Comment 3 Tim Burke 2004-11-03 22:29:45 UTC
Is this still an issue in RHEL4 RC tree?


Comment 4 David Woodhouse 2004-11-04 22:59:42 UTC
Yes, it's still not built. The ppc version builds fine but it looks like the
x86_64 build was failing even before I enabled PPC.

Comment 5 Jay Turner 2004-11-05 09:41:37 UTC
I'm not sure that I follow at all.  numactl-0.6.4-1.9 is built into fc3-base and
is the latest version of the package that I find in Beehive (and is also what's
in Beta2).  The spec file contains:

ExcludeArch: ppc64 s390 s390x ppc
  
And indeed the package is built for i386, ia64 and x86_64.  I don't follow the
comments about "it's just the other architectures don't build (and didn't
before)" and "the x86_64 build was failing even before I enabled PPC."  Are you
saying that you've got a new version of the package which only builds on ppc32?

Comment 6 David Woodhouse 2004-11-05 12:10:23 UTC
I'm saying that I added a trivial patch to make it build on PPC, and
it built fine for me so I put it through beehive... and it failed due
to the x86_64 build failing. All my changes were in #ifdef __PPC__.

Comment 7 Jay Turner 2004-11-12 12:09:32 UTC
David, still seeing the issues attempting to get this package through Beehive?

Comment 8 David Woodhouse 2004-11-12 12:13:25 UTC
Er, sorry - no. I managed to build it yesterday with a lot of help
from Alex Oliva in working out why it was failing on x86_64. It's
0.6.4-1.12 in 4E-HEAD. I should also build for FC4, I suppose. Should
I be building in one place and then moving it, or just building twice?

Comment 12 Jay Turner 2004-11-18 11:04:05 UTC
Fix confirmed with the RHEL4-re1117.0 tree.  numactl-0.6.4-1.12 is included for
ppc, i386, ia64 and x86_64 (leaving s390/s390x as it should be.)


Note You need to log in before you can comment on or make changes to this bug.