This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 136674 - gnome-session hangs if network connection is interrupted
gnome-session hangs if network connection is interrupted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libSM (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2004-10-21 12:23 EDT by Dan Williams
Modified: 2014-06-18 05:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 14:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2004-10-21 12:23:03 EDT
Gnome session hangs trying to create a client ID if you are connected
to a network and can't contact a nameserver.  For example, connect to
vpnonly and don't bring up the VPN.

Start gedit, gedit never starts

Gedit backtrace during hang:
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xf6f4e4b3 in __read_nocancel () from /lib/tls/libpthread.so.0
#2  0xf6fc6f29 in _IceTransFreeConnInfo () from /usr/X11R6/lib/libICE.so.6
#3  0xf6fc7375 in _IceTransRead () from /usr/X11R6/lib/libICE.so.6
#4  0xf6fbf2c9 in _IceRead () from /usr/X11R6/lib/libICE.so.6
#5  0xf6fbf857 in IceProcessMessages () from /usr/X11R6/lib/libICE.so.6
#6  0xf6fc471a in IceProtocolSetup () from /usr/X11R6/lib/libICE.so.6
#7  0xf6fd2250 in SmcOpenConnection () from /usr/X11R6/lib/libSM.so.6
#8  0x0368cdf7 in gnome_client_connect () from /usr/lib/libgnomeui-2.so.0
#9  0x0368cf34 in gnome_client_new () from /usr/lib/libgnomeui-2.so.0
#10 0x0361ae2e in gnome_program_postinit () from /usr/lib/libgnome-2.so.0
#11 0x0361b1d6 in gnome_program_postinit () from /usr/lib/libgnome-2.so.0
#12 0x0361b50f in gnome_program_init () from /usr/lib/libgnome-2.so.0
#13 0x0805fd2b in main ()


The client is stuck attempting to read from the session manager, which
is stuck trying to look up its address forever.

Gnome-session backtrace during hang:
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xf6a3b52d in poll () from /lib/tls/libc.so.6
#2  0xf691391c in __libc_res_nsend () from /lib/libresolv.so.2
#3  0xf6912073 in __libc_res_nquery () from /lib/libresolv.so.2
#4  0xf6912338 in __libc_res_nquerydomain () from /lib/libresolv.so.2
#5  0xf691289e in __libc_res_nsearch () from /lib/libresolv.so.2
#6  0xf66b32de in _nss_dns_gethostbyname3_r () from /lib/libnss_dns.so.2
#7  0xf66b3533 in _nss_dns_gethostbyname2_r () from /lib/libnss_dns.so.2
#8  0xf6a2d2a2 in gaih_inet () from /lib/tls/libc.so.6
#9  0xf6a2e591 in getaddrinfo () from /lib/tls/libc.so.6
#10 0xf6f011e5 in SmsGenerateClientID () from /usr/X11R6/lib/libSM.so.6
#11 0x0805267d in start_clients ()
#12 0xf6f0383a in _SmsProcessMessage () from /usr/X11R6/lib/libSM.so.6
#13 0xf6eed99d in IceProcessMessages () from /usr/X11R6/lib/libICE.so.6
#14 0x03663a9f in gnome_href_set_label () from /usr/lib/libgnomeui-2.so.0
#15 0x009d5907 in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#16 0x009b174b in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#17 0x009b31d2 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#18 0x009b347f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#19 0xf6d0278e in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x0805497b in main ()


The problem is in frame "#10 0xf6f011e5 in SmsGenerateClientID ()",
where gnome-session keeps trying to get a client id based on your
hostname or something.  Why the does the SM need something as fragile
as the hostname, and why does it need to do any lookups on it?
Comment 1 Dan Williams 2004-10-21 12:24:23 EDT
So maybe its an Xorg bug if libSM.so is where the problem is occuring?
Comment 2 marcelo espinoza 2004-11-17 18:06:56 EST
Hello, I am having the same problem with GNOME under Fedora 3 fully
updated. My cable modem has a button for "stand by", so when I press
it to stop my internet connection (I am receiving a stream of packages
which I don't know what they are, so I just stop the internet).
Anyway, when I interrupt my network connection, GNOME does not allow
me to do anything. I tried:
- to open a terminal, it never opens.
- to log out, I never got the message of log out, never happened.

Now, during this strange hang out, I can run some applications like
GIMP, but I can not open a Terminal in this way. 
 
Comment 3 Matthias Clasen 2006-11-26 13:00:47 EST
Moving to libSM according to comment 1. 
I believe this problem still exists in FC6.
Comment 5 Matthias Clasen 2007-10-10 14:32:24 EDT
I believe ajax did some fixes in this area recently. Ajax ?
Comment 6 Jeremy Katz 2007-10-24 14:32:15 EDT
Yep, this is fixed for F8

Note You need to log in before you can comment on or make changes to this bug.