Bug 136681 - add default sysconfig file with documentation for init scripts
Summary: add default sysconfig file with documentation for init scripts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-21 17:01 UTC by Adam "mantis" Manthei
Modified: 2010-01-12 03:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 20:38:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam "mantis" Manthei 2004-10-21 17:01:07 UTC
Description of problem:
Steve Whitehouse has requested that a default sysconfig file be
installed at /etc/sysconfig/gfs that contains documentation of the
configurable parameters and their defaults for the init.d scripts.

The request seems pretty reasonable.  The RPM just needs to make sure
that when it installs the file, it doesn't overwrite an existing
/etc/sysconfig/gfs file unless it has not been altered since its
previous version.

Version-Release number of selected component (if applicable):
Not available in GFS-6.0.0-15 and earlier.

Comment 1 Adam "mantis" Manthei 2004-10-21 17:02:17 UTC
This file has been added to CVS, but not to the `make install` target.

reassigning to Jon Brassow for inclusion in the RPMs

Comment 2 Chris Feist 2004-11-09 21:20:14 UTC
I added an install line to the makefile, and marked the file as
%config in the .spec file so the file will not be overwritten on an
rpm upgrade/install.

This rpm should be built in the next couple of days.

Comment 3 Lon Hohberger 2009-12-22 20:38:54 UTC
Cleanup.

This bugzilla should be resolved with the current packages from RHN for Red Hat Global File System for Red Hat Enterprise Linux 3.

GFS-6.0.2.36-9


Note You need to log in before you can comment on or make changes to this bug.