Bug 136687 - ldap_auth cache not working
Summary: ldap_auth cache not working
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: 2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-21 17:50 UTC by Ed Swierk
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.0.52-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 15:26:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Swierk 2004-10-21 17:50:37 UTC
Description of problem:

On FC2 x86_64, the httpd ldap_auth cache is not getting initialized.

Version-Release number of selected component (if applicable):

httpd-2.0.51-2.7

How reproducible:

Always

Steps to Reproduce:
1. Create /etc/httpd/conf.d/ldap.conf:

  <Location /ldap-status>
      SetHandler ldap-status
  </Location>

  LDAPCacheEntries 1024
  LDAPOpCacheEntries 1024

2. Restart httpd

3. Navigate to http://localhost/ldap-status/
  
Actual results:

LDAP Cache Information table says "Cache has not been
enabled/initialised."

Expected results:

The LDAP cache should be enabled.

Comment 1 Ed Swierk 2004-10-21 18:34:43 UTC
I've found a workaround.  When I rebuild the httpd-2.0.51-2.7 from
source, with httpd-2.0.47-ldapshm.patch and
httpd-2.0.51-ldap50to51.patch commented out, the LDAP cache works fine.

This is an important fix for people using Apache as a Subversion
server. Subversion touches many files during certain operations, such
as svn log.  A 5-second log operation can take more than 15 minutes
when the LDAP cache is disabled.

Comment 2 Joe Orton 2004-10-21 19:05:45 UTC
Thanks for the report.  Was it working with the same configuration
before you updated to 2.0.51?

Comment 3 Ed Swierk 2004-10-21 20:42:08 UTC
No, LDAP authentication caching is also broken in httpd-2.0.49-4.


Comment 4 Joe Orton 2004-11-11 15:26:25 UTC
The LDAP modules are in-line with upstream as of the Fedora Core 3
httpd-2.0.52-3 package, so this should be working as of current
releases.  The changes to improve the caching code made since FC2's
original 2.0.49 cause backwards-compatibility issues so won't be included.


Note You need to log in before you can comment on or make changes to this bug.