Bug 1366888 - An internal error occurred during: "Checking files...".
Summary: An internal error occurred during: "Checking files...".
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-checkstyle
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rob
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2072660950;VARIANT_ID=works...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-14 08:00 UTC by James H (Jim) Bills
Modified: 2017-06-09 18:56 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-09 18:56:17 UTC


Attachments (Terms of Use)
File: backtrace (1.12 KB, text/plain)
2016-08-14 08:00 UTC, James H (Jim) Bills
no flags Details

Description James H (Jim) Bills 2016-08-14 08:00:35 UTC
Description of problem:
Opened eclipse with after removing my old ~/.eclipse directory.
Opened an previous workspace.
Opened a java source file.
Right clicked on the java source and selected ‘Checkstyle>Check Code with Checkstyle’ from the pop-up menu.
A error pop-up window opens with the following detail:

  An internal error occurred during: "Checking files...".
  Could not initialize class net.sf.eclipsecs.core.builder.CheckerFactory

Version-Release number of selected component:
eclipse-platform-4.6.0-3.fc24

Additional info:
reporter:       libreport-2.7.2
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.8 -Xms128m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160714-1000.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.6.0.v20160714-1000/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.400.v20160714-1000/eclipse_1617.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160714-1000.jar -protect master --launcher.appendVmargs -exitdata 778019 -clean -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.8 -Xms128m -Xmx1024m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.200.v20160714-1000.jar
eclipseplugin:  org.eclipse.core.jobs
executable:     /usr/lib64/eclipse/plugins/org.eclipse.core.jobs_3.8.0.v20160714-1000.jar
kernel:         4.6.5-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           libreport
uid:            1000

Truncated backtrace:
java.lang.NoClassDefFoundError: org/eclipse/jdt/core/JavaModelException
	at net.sf.eclipsecs.core.builder.CheckerFactory.<clinit>(CheckerFactory.java:92)
	at net.sf.eclipsecs.core.builder.Auditor.runAudit(Auditor.java:142)
	at net.sf.eclipsecs.core.builder.CheckstyleBuilder.handleBuildSelection(CheckstyleBuilder.java:300)
	at net.sf.eclipsecs.core.jobs.RunCheckstyleOnFilesJob.runInWorkspace(RunCheckstyleOnFilesJob.java:116)
	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: java.lang.ClassNotFoundException: org.eclipse.jdt.core.JavaModelException cannot be found by net.sf.eclipsecs.core_6.11.1.201602032054
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:398)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:361)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:353)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 6 more

Comment 1 James H (Jim) Bills 2016-08-14 08:00:41 UTC
Created attachment 1190754 [details]
File: backtrace

Comment 2 Roland Grunberg 2016-10-25 16:21:29 UTC
Could you try the same against the latest version of Eclipse in Fedora 24 ? As far as I can see net.sf.eclipsecs.core_6.11.1.201602032054 from eclipse-checkstyle depends on eclipse-jdt and has proper Import-Package on it so it should be resolving.

Comment 3 Fedora Update System 2017-05-12 13:50:04 UTC
eclipse-checkstyle-7.6.0-1.fc26 checkstyle-7.7-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-91070b5f04

Comment 4 Fedora Update System 2017-05-13 01:13:38 UTC
checkstyle-7.7-1.fc26, eclipse-checkstyle-7.6.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-91070b5f04

Comment 5 Fedora Update System 2017-06-09 18:56:17 UTC
checkstyle-7.7-1.fc26, eclipse-checkstyle-7.6.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.