Bug 1366917 - Building PyPI pkg with python2 ez_setup.py fails
Summary: Building PyPI pkg with python2 ez_setup.py fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyp2rpm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Cyprian
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-14 21:43 UTC by Adam Samalik
Modified: 2016-11-19 21:03 UTC (History)
3 users (show)

Fixed In Version: pyp2rpm-3.2.1-1.fc24 pyp2rpm-3.2.1-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-10 03:22:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Samalik 2016-08-14 21:43:06 UTC
Description of problem:
I tried to build a package from PyPI that uses ez_setup.py script that only runs on Python 2. It failed on syntax error because it was run on Python 3.

Build: https://copr.fedorainfracloud.org/coprs/asamalik/QSToolKit/build/441349/
Log: http://copr-dist-git.fedorainfracloud.org/per-task-logs/441349-f24.log
 

How reproducible:
easily

Steps to Reproduce:
1. Build QSTK package from PyPI using python 2 only.


Actual results:
Failed.

Expected results:
At least imported into dist-git. When a PyPI pkg is only for Python 2, Copr should use Python 2 to generate the SPEC file.

Additional info:

Comment 1 Miroslav Suchý 2016-08-15 11:07:44 UTC
Already reported to upstream. See:
https://github.com/fedora-python/pyp2rpm/issues/47

Comment 2 Fedora Update System 2016-10-28 14:55:29 UTC
pyp2rpm-3.2.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3057e5d55e

Comment 3 Fedora Update System 2016-10-29 03:55:11 UTC
pyp2rpm-3.2.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-70ce6402b3

Comment 4 Fedora Update System 2016-11-10 03:22:50 UTC
pyp2rpm-3.2.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2016-11-19 21:03:03 UTC
pyp2rpm-3.2.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.