Bug 1367099 - Weird FG/BG colors make selected text vanish.
Summary: Weird FG/BG colors make selected text vanish.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-15 13:55 UTC by Nils Philippsen
Modified: 2016-10-21 15:51 UTC (History)
4 users (show)

Fixed In Version: chromium-52.0.2743.116-9.fc24 chromium-52.0.2743.116-10.fc25 chromium-52.0.2743.116-10.fc23 chromium-53.0.2785.143-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-21 15:51:45 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot exhibiting the problem (64.37 KB, image/png)
2016-08-17 15:48 UTC, Nils Philippsen
no flags Details
Screenshot with the latest test version (315.22 KB, image/png)
2016-08-18 12:01 UTC, Bart Ratgers
no flags Details

Description Nils Philippsen 2016-08-15 13:55:18 UTC
Description of problem:
The chromium that has landed in Fedora apparently comes with a couple of changed default colors, some seem badly chosen(?), so that e.g. selecting black-on-white text makes the text color white -> invisible.

Version-Release number of selected component (if applicable):
chromium-52.0.2743.116-1.fc24.x86_64

How reproducible:
Reproducible

Steps to Reproduce:
1. Select some black-on-white text, e.g. here in Bugzilla.

Actual results:
Selected text is white-on-white, invisible.

Expected results:
Selected text has a sensible foreground-background color combination so it remains readable.

Additional info:
Previous (COPR) version worked fine in that regard: chromium-52.0.2743.116-1.fc24.x86_64

The other updated components don't look like they could contribute to the problem to me: https://paste.fedoraproject.org/408792/69231147/

Comment 1 Nils Philippsen 2016-08-15 13:56:33 UTC
Dang, the previous version was chromium-52.0.2743.82-9.fc24.x86_64 of course.

Comment 2 Nils Philippsen 2016-08-15 13:57:56 UTC
NB: The "it's loading" tab throbber is white-on-light-grey now. That's probably connected.

Comment 3 Tom "spot" Callaway 2016-08-15 17:16:41 UTC
I wonder if this is the "enable_hidpi" flag causing trouble.

Can you provide a URL that really shows off this problem?

Comment 4 Nils Philippsen 2016-08-17 15:47:38 UTC
This right page right here exhibits it just fine. I've selected the last sentence of your comment, and will attach a screenshot of it.

Comment 5 Nils Philippsen 2016-08-17 15:48:17 UTC
Created attachment 1191668 [details]
Screenshot exhibiting the problem

Comment 6 Nils Philippsen 2016-08-17 15:49:39 UTC
Minus one "right"...

Comment 7 Fedora Update System 2016-08-17 17:34:40 UTC
chromium-52.0.2743.116-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-19c0d6b4b2

Comment 8 Fedora Update System 2016-08-17 17:35:06 UTC
chromium-52.0.2743.116-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0

Comment 9 Fedora Update System 2016-08-17 17:35:26 UTC
chromium-52.0.2743.116-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a35f3eeea

Comment 10 Fedora Update System 2016-08-17 17:35:48 UTC
chromium-52.0.2743.116-9.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-95d9b62ed3

Comment 11 Fedora Update System 2016-08-17 19:51:56 UTC
chromium-52.0.2743.116-9.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-95d9b62ed3

Comment 12 Fedora Update System 2016-08-18 01:50:07 UTC
chromium-52.0.2743.116-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a35f3eeea

Comment 13 Fedora Update System 2016-08-18 01:51:06 UTC
chromium-52.0.2743.116-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0

Comment 14 Fedora Update System 2016-08-18 04:18:25 UTC
chromium-52.0.2743.116-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-19c0d6b4b2

Comment 15 Bart Ratgers 2016-08-18 12:01:48 UTC
Created attachment 1191862 [details]
Screenshot with the latest test version

The bug still exist in the  latest test version of chromium. In the red ellipse the text is selected and disappears completely.

Comment 16 Tom "spot" Callaway 2016-08-18 13:30:39 UTC
Which version of Fedora are you using? Are you running GNOME? Is Wayland enabled?

Comment 17 Bart Ratgers 2016-08-18 14:06:58 UTC
I'm running the latest version of Fedora 24 in a GNOME desktop (Wayland is not enabled).

XDG_CURRENT_DESKTOP=GNOME
GDMSESSION=gnome


Only the chromium browser RPMS came form the updates-testing repository:
chromium-libs-media-52.0.2743.116-9.fc24.x86_64
chromium-52.0.2743.116-9.fc24.x86_64
chromium-libs-52.0.2743.116-9.fc24.x86_64

The other on from the default 'production' repository:
gdm-3.20.1-3.fc24.x86_64
gnome-shell-3.20.3-3.fc24.x86_64

Comment 18 Tom "spot" Callaway 2016-08-18 19:39:44 UTC
Please try with -10:

http://koji.fedoraproject.org/koji/buildinfo?buildID=792919

Comment 19 Bart Ratgers 2016-08-18 20:40:29 UTC
Everything seems to work again, selecting text and the resolution (HiDPI). 
Sadly I miss the save and open dialogs.

Comment 20 Tom "spot" Callaway 2016-08-18 20:55:19 UTC
It looks like their gtk3 support is woefully incomplete. Maybe file a bug upstream?

Comment 21 Robert Buchholz 2016-08-24 08:28:00 UTC
I can confirm that -10 fixes this problem. If I read https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0 correctly, others are saying that -9 does not.

Comment 22 Fedora Update System 2016-08-25 13:54:29 UTC
chromium-52.0.2743.116-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2016-08-26 13:32:53 UTC
chromium-52.0.2743.116-10.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2a0c80295c

Comment 24 Fedora Update System 2016-08-26 13:33:29 UTC
chromium-52.0.2743.116-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a8d9311f8

Comment 25 Fedora Update System 2016-08-27 12:53:13 UTC
chromium-52.0.2743.116-10.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2a0c80295c

Comment 26 Fedora Update System 2016-08-27 22:21:44 UTC
chromium-52.0.2743.116-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a8d9311f8

Comment 27 Fedora Update System 2016-08-29 19:25:53 UTC
chromium-52.0.2743.116-11.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e82affa05e

Comment 28 Fedora Update System 2016-08-31 13:49:48 UTC
chromium-52.0.2743.116-11.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e82affa05e

Comment 29 Fedora Update System 2016-08-31 16:28:37 UTC
chromium-52.0.2743.116-10.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2016-09-09 16:54:47 UTC
chromium-52.0.2743.116-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2016-09-09 19:07:54 UTC
chromium-53.0.2785.101-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6d70ae9a57

Comment 32 Fedora Update System 2016-09-10 05:48:44 UTC
chromium-53.0.2785.101-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6d70ae9a57

Comment 33 Fedora Update System 2016-09-14 19:28:34 UTC
chromium-53.0.2785.113-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-449d647265

Comment 34 Fedora Update System 2016-09-15 23:52:09 UTC
chromium-53.0.2785.113-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-449d647265

Comment 35 Fedora Update System 2016-09-28 16:19:45 UTC
chromium-53.0.2785.116-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bf5b9b3332

Comment 36 Fedora Update System 2016-10-04 13:19:38 UTC
chromium-53.0.2785.143-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-387d58ef27

Comment 37 Fedora Update System 2016-10-21 15:51:45 UTC
chromium-53.0.2785.143-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.