Bug 1367126 - [RFE] upload FQDN with facts
Summary: [RFE] upload FQDN with facts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.2
Hardware: x86_64
OS: Linux
high
low
Target Milestone: rc
: 7.4
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 1395274 1367128
TreeView+ depends on / blocked
 
Reported: 2016-08-15 15:46 UTC by Justin Sherrill
Modified: 2020-09-10 09:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1367128 (view as bug list)
Environment:
Last Closed: 2017-08-01 19:18:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1508 None closed 1367128: Add network.fqdn fact 2020-02-05 01:16:54 UTC
Red Hat Bugzilla 1356714 None CLOSED After upgrade, all of my hosts are duplicated one with shortname, one with fqdn 2019-09-11 04:11:53 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Justin Sherrill 2016-08-15 15:46:37 UTC
Description of problem:

Currently subscription-manager does not upload fqdn with its facts, only equivalent of 'hostname'.  It would be very useful for it to also upload the equivalent of 'hostname -f'

I expect this would be uploaded as something like 'network.fqdn'


Version-Release number of selected component (if applicable):
subscription-manager-1.15.9-15.el7

How reproducible:
always

Steps to Reproduce:
1.  configure your system such that 'hostname' returns the host's shortname, and 'hostname -f' returns the fqdn
2.  Run 'subscription-manager facts --list | grep fqdn'

Actual results:
no fqdn listed


Expected results:
should upload fqdn.

Additional info:
This is extremely important for Satellite 6.2 and we are planning on building in support for this fact.

Some 3rd party software requires 'hostname' be set to the shortname.

Comment 3 Rehana 2017-04-19 10:36:05 UTC
Retested on ;

subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.8-1.el7
python-rhsm: 1.19.5-1.el7


The test system is configured to have a short hostname along with FQDN 

# hostname
bkr-hv03-guest06.dsal.lab.eng.bos.redhat.com


# hostname -s
bkr-hv03-guest06


# hostname -f
bkr-hv03-guest06.dsal.lab.eng.bos.redhat.com

Now verify the fact value of network.fqdn,

# subscription-manager facts --list | grep fqdn
network.fqdn: bkr-hv03-guest06.dsal.lab.eng.bos.redhat.com

# subscription-manager facts --list | grep network
network.fqdn: bkr-hv03-guest06.dsal.lab.eng.bos.redhat.com
network.hostname: bkr-hv03-guest06.dsal.lab.eng.bos.redhat.com


Observed that now fqdn fact value is collected along with the already existing fact network.hostname.

Marking as Verified!!

Comment 4 errata-xmlrpc 2017-08-01 19:18:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.